WordPress.org

Ready to get started?Download WordPress

Forums

Widget Plugin installation help (19 posts)

  1. Babak
    Member
    Posted 8 years ago #

    I followed the instructions at Automattic (http://automattic.com/code/widgets/use/) but its not working.

    Please help. Here are the details:

    I'm using K2 and WP2.x

    I downloaded the zip file 'widgets'
    unzipped it
    uploaded files/folders as follows:

    rss.png went into: wp-includes/images
    scriptculous (folder) went into: wp-includes/js
    delicious.php ]\
    gsearch.php ] (inside 'widgets' folder) into: plugins
    widgets.php ]/

    the folders 'classic' and 'default' into 'widgets' folder (so they went to plugins as well)

    The reason I put the classic and default folders there is because it mentions in the instructions on the Automattic site to put all php in 'widgets' folder. And those two folders (classic/default) both contain php files.

    As well, I couldn't put them where Automattic indicates in their tree graph because putting them in my themes folder would have overwritten the classic and default files there!

    Sheesh...

    Anyway, that is how its setup on my server. I went to the plugins and activated all 3 (widgets, gsearch and delicious).

    Then clicked on presentation.

    Nothing.

    Its the same.

    Since I'm using K2 (which is widgetized) I wasn't expecting that.

    So I switched to kubrick.

    nothing.

    (sigh)

    Any ideas? All help appreciated.

    Thank you.

  2. Babak
    Member
    Posted 8 years ago #

    Update: I tried the suggestion here:
    http://wordpress.org/support/topic/67871?replies=4

    And put the default folder (w/php files) into the themes (that is I overwrote the two php files)

    nothing.

    ?????

  3. Babak
    Member
    Posted 8 years ago #

    uh, anyone?

  4. obeattie
    Member
    Posted 8 years ago #

    Same problem

  5. MichaelH
    Member
    Posted 8 years ago #

    Don't know if this is proper, but I just extracted the files into the plugins folder and moved the classic and default files to their themes folders.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    The classic and default are modified themes, they should replace the existing theme folders in the themes directory.

    If you're not using the classic or default themes, then you will need to modify your theme to include support for widgets, or use another theme that has widgets support.

  7. tachyonxero
    Member
    Posted 8 years ago #

    I am having the same problem and all my themes do support widgets.

  8. mickemus
    Member
    Posted 8 years ago #

    have you activated the default theme?

  9. cryptomnesia
    Member
    Posted 7 years ago #

    i got the same problem going on. i suppose i'll try to contact automattic about it, considering there are a few people with the same issues. ive tried everything on my end that i can think of.

    ill letcha know if i find anything..

  10. cryptomnesia
    Member
    Posted 7 years ago #

    well that was rather daft of me.. i figured it out.

    looks like it was just a question of copying the functions.php into the proper directory.

    i was using the fspring theme which is "widgets enabled." however there was no functions.php included with the package. i didnt notice this and kept tinkering with sidebar.php

    all set now!

  11. blakcitrus
    Member
    Posted 7 years ago #

    I'm using the updated chaotic soul theme and I have downloaded the widgets file but still no widgets option on the Presentation bar?

  12. NGEvo
    Member
    Posted 7 years ago #

    I think that the Widgets Plugin isn't compatible with WP 2.1.
    :(

    Is there a solution anyone?

  13. NGEvo
    Member
    Posted 7 years ago #

    Anything? Anyone?

  14. Daynah
    Member
    Posted 7 years ago #

    If I'm reading your first post correctly, I think the files are in the wrong places. Everything (except the classical and default folders) should be in a folder called "widgets" which is inside "plugins", which is inside "wp-content".

    http://automattic.com/code/widgets/use/
    wp-content -> plugins -> widgets -> scriptaculous

    Which means all the javascript files will be widgets folder as well.

    After uploading the files here, you will have to go to Admin -> Plugins

    and turn on each widget.

    Then go to Presentation -> Sidebar Widgets

    Then drag and drop the widgets you want on your page.

    "Sidebar Widgets" will only be turned on for themes with widgets.

  15. BeeDub
    Member
    Posted 7 years ago #

    Cryptomnesia states that they 'copied the functions.php' into the proper directory.

    Where did you find it since it wasn't included in the package. And what directory did you copy it to?

    I am relieved to see that there are others having the same prob.

  16. NGEvo
    Member
    Posted 7 years ago #

    I installed everything correctly, I just don't see Widgets under Presentation. :(

  17. NGEvo
    Member
    Posted 7 years ago #

    there must be a solution... I want to use Widgets!

  18. kafemarat
    Member
    Posted 7 years ago #

    i had the same problem, found this thread and i think i figured it out. well, at least it works for me.

    in the widget.zip you find 2 folders. one named classic, one named default. each folder contains two files:
    a) functions.php and b) sidebar.php

    move functions.php and sidebar.php from the classic folder to /wp-content/themes/classic/

    move functions.php and sidebar.php from the default folder to /wp-content/themes/default/

    go to your admin panel and change your default theme to either wordpress classic 1.5 or to wordpress default 1.6

    you should see the new widget menu then.

    for all the people who don't want to use the classic or default theme, it's at least a way to see if it's "only" a template problem or a system problem.

  19. CynaraJane
    Member
    Posted 7 years ago #

    I am also having the same problem. I have followed kafemarat's instructions hoping for the best and...nothing.

Topic Closed

This topic has been closed to new replies.

About this Topic