WordPress.org

Ready to get started?Download WordPress

Forums

Responsive
Widget Issues After Theme Update (34 posts)

  1. rwneal
    Member
    Posted 5 months ago #

    Hi,

    My site is http://www.oneatatimefoundation.org.au. It uses a child theme containign a few minor mods on the 1.9.3.9 version of the responsive theme.

    I recently had an issue after I updated to responsive version 1.9.5.0. Basically the three widgets on the front page reverted to the default text and formatting, and the Appearance/Widgets option disappeared from my dashboard. I tried deactivating all my plugins (some of which had also recently updated), but this didn't solve the problem. I then switched to the twentyten theme and the Appearance/Widgets option returned to the dashboard.

    Fortunatly I had a copy of the 1.9.3.9 version held locally so I was able to switch back. Again the Appearance/Widgets option was present and I was able to restore the widgets to how they were.

    Does anyone have any idea why this happened, and how I can update to the latest version of Responsive without losing my widgets?

    Thanks in advance for any help.

  2. mulli.bahr
    Member
    Posted 5 months ago #

    I had the SAME problem & forunately the SAME backup... :-)
    My site is http://prizma-il.com
    I wish I had an idea...

    One more cent: I have my debug on - no errors are reported.

  3. Resin
    Member
    Posted 5 months ago #

    I have the same problem with http://madmedmia.dk so not I cannot see/setup my widgets :(
    Sadly I dont have a backup so I cant roll back.

  4. mulli.bahr
    Member
    Posted 5 months ago #

    Widgets are not lost!
    Just downgrade by pasting previous version.
    If you neeed help - call me

  5. tnhwyman
    Member
    Posted 5 months ago #

    Wish I had come here before update....i would have been in bed yesterday.

  6. fssbob
    Member
    Posted 5 months ago #

    Same issue after installing 1.9.5.0. (Fortunately I tried it first on my test site.) The problem didn't exist in 1.9.4.9.

  7. dagb
    Member
    Posted 5 months ago #

    Thought I could workaround the issue, by opening the widget edit page manually (http://hostname/wp-admin/widgets.php) but got only a page saying my theme does not support widgets. If CyberChimps (Responsive WordPress Themes You Can Trust) intended to remove support for widgets, it is not funny that it was not warned beforehand.

  8. Gary Eckstein
    Member
    Posted 5 months ago #

    I've seen exactly the same issue where widgets are not accessible.

  9. tenchoc
    Member
    Posted 5 months ago #

    yeah what's the deal here - can't find my widgets. i don't have a backup - mulli.bahr - can you please advise how to downgrade?

  10. marcusasiabc
    Member
    Posted 5 months ago #

    Same issue after installing 1.9.5.0.
    I've seen exactly the same issue where widgets are not accessible.
    my page goes so bad

  11. tenchoc
    Member
    Posted 5 months ago #

    ok i went to the CyberChimps website and saw that in their support forum they have a link for how to download the downgraded version so the widgets can work again - you can find the links here:

    http://cyberchimps.com/forum-topic/update-1-9-5-0-widgets-disappeared-from-dashboard/

  12. thomvincent
    Member
    Posted 5 months ago #

    Instead of rolling back the theme you can temporarily re-register the widgets again in your functions.php file.

    function homeWidget1_init() {
    	register_sidebar( array(
    		'name' => 'Home widget 1',
    		'id' => 'home-widget-1'
    	) );
    }
    function homeWidget2_init() {
    	register_sidebar( array(
    		'name' => 'Home widget 2',
    		'id' => 'home-widget-2'
    	) );
    }
    function homeWidget3_init() {
    	register_sidebar( array(
    		'name' => 'Home widget 3',
    		'id' => 'home-widget-3'
    	) );
    }
    add_action( 'widgets_init', 'homeWidget1_init' );
    add_action( 'widgets_init', 'homeWidget2_init' );
    add_action( 'widgets_init', 'homeWidget3_init' );
  13. minilobo
    Member
    Posted 5 months ago #

    Thanks @thomvincent , that works for the home page, but not for the sidebar :)

  14. mulli.bahr
    Member
    Posted 5 months ago #

    tenchoc, thanks.
    I simply unzipped the theme from my backup.

    BUT, now I wonder whether cyberchimp will remove the new update,
    which really calls people to upgrade and bump into this issue.

    This can save a lot of time, thousands of hours!.

  15. eselsstieg78
    Member
    Posted 5 months ago #

    This was a bug in 1.9.5.0 ... Upgrade to 1.9.5.1 works fine for me!

    Try this under Current Version here

    If you're widget don't work, put it from the right sidebar to the main sidebar.

  16. zivam
    Member
    Posted 5 months ago #

    1.9.5.1 - ok

  17. neil_seddon
    Member
    Posted 5 months ago #

    Hi,

    I made the update in my child theme. Same issue with the widgets option vanishing?

    Could someone advise the best way for this to be up and running even if I have to install an older version.

    I'm a bit of a learner with this stuff so your help will be appreciated.

  18. AndyiBM
    Member
    Posted 5 months ago #

    It's not just widgets vanishing... some styling (e.g. .menu) has disappeared too, meaning I will need add more to my child theme. I have downgraded too until further notice.

  19. Silvertass
    Member
    Posted 5 months ago #

    I had widgets on the right side, under first page on some half pages before. Now they are al gone. This update was no good :-(
    I don't wan't to mess whis this before I know if the proframers had a purpose whit this or if they only had a bad day. Could we please have an answer to that!!!

  20. Silvertass
    Member
    Posted 5 months ago #

    Downgrade seems like a very good thing to do. Can any one tell me how to do that :-)

  21. neil_seddon
    Member
    Posted 5 months ago #

    I'm with you Silvertass. How can I upload an old version easily. Does anyone know when the version to correct all this will be available?

  22. Silvertass
    Member
    Posted 5 months ago #

    I read in the description of version 1.9.5.0 that it should look like the previously version. Hopfully they will correct it when they notice that it's gone wrong. I will just wait a few hours or try to upprade to 1.9.5.1. (Not realy sure how to do that)

  23. neil_seddon
    Member
    Posted 5 months ago #

    They reckon 1.9.5.1 is better above I think.

    What if the hosting company rolls the site back a day prior to the update. Will that fix this issue?

  24. Silvertass
    Member
    Posted 5 months ago #

    Here are some versions that Perhaps can be usefull if nothing happens.
    http://wordpress.org/themes/responsive/developers/

  25. Steven Jay Cohen
    Member
    Posted 5 months ago #

    Downgraded to 1.9.4.9

    My Front Page Widgets were restored, but my Colophon Widget lost its content.

  26. Silvertass
    Member
    Posted 5 months ago #

    Yes, your idea is good, try that ;-) They done that for me before! Good luck!

  27. Silvertass
    Member
    Posted 5 months ago #

    Sad ;-( Don't you have the text saved anywere else?

  28. Steven Jay Cohen
    Member
    Posted 5 months ago #

    I do, just pointing out the different behavior between widgets. It would seem to point to a flaw in the underlying widget code if some are remembered and some are forgotten.

  29. neil_seddon
    Member
    Posted 5 months ago #

    How do I see my current version of this theme and can I also see my previous version of the theme.

    I'm going to live chat Bluhost so I want to give them the correct info.

  30. Andykev
    Member
    Posted 5 months ago #

    Lost my widgets! Thanks to Cyberchimps for the fast rollout of the fix.
    Using this restored my Dashboard WIDGET control. However the CONTENT was missing. Looked under "Inactive" and there they were! Just moved the HTML text into the widget (I use Black Studio MCE) in the widget box. All are ok. Had to do the same with the sidebar. Now I have HTML text backup for all my widgets, to match my pages. Did not bother with the chore of roll back or SQL PhP updates thru FTP. I guess stuff happens. This company was much faster than say...that photo gallery one!

Reply »

You must log in to post.

About this Theme

About this Topic