WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
widget doesn't show up on the page (38 posts)

  1. FXfreelance
    Member
    Posted 1 year ago #

    Hi, my old twitter plugin was disconnected and stop working. So I just installed the Pro one. Unfortunatelly can't make it work - nothing is showing up on the page. I add it to the right sidebar, twitter name - fxfreelance. I tried to change the number of feeded tweets like in one of the threads here, but it doesn't help. Number of API rewuests far from limits, I don't know what else to check. Any typical things I can do wrong, or is the problem not with me?

    It should be below "@fxfreelance tweets" and above the next time-zone widget.

    Thanks,
    M

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. albpara
    Member
    Posted 1 year ago #

    Same problem here... I'm not ablre to figure out what I am doing wrong

  3. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    You might want to check to make sure that scheduled posts work on your site. The requests to Twitter are triggered much the same way (some poor server configs cause a problem with this). Also, have you tested it with no other plugins? It's possible there's a conflict somewhere.

  4. Ed Parker
    Member
    Posted 1 year ago #

    +1 for the widget not showing up post update to 2.41

  5. Ryan Andrews
    Member
    Posted 1 year ago #

    I agree that the widget is not showing up. This is the only code displayed where the widget should be:

    li li

  6. FXfreelance
    Member
    Posted 1 year ago #

    I did not do anything at all, but now it doesn show up by itself, so was some temp problem with the widget.

  7. Jim Walsh
    Member
    Posted 1 year ago #

    This and other Twitter widgets and plugins dont work anymore because of the Twitter API changes. The simple JSON URLs they were using to pull tweets have been disabled by Twitter.

  8. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    Jim: that's not true. It works fine and will continue to work until March when Twitter makes the change. By then I should have authentication added so it will still be fine.

  9. amichel86
    Member
    Posted 1 year ago #

    Same here. Updated to new version and nothing shows up on the page.

  10. amichel86
    Member
    Posted 1 year ago #

    I found the solution. In the plugin's settings change

    Use Twitter API via HTTPS
    to
    Use Twitter API via HTTP

    The widget then appeared!

  11. freshwaters
    Member
    Posted 1 year ago #

    Hi guys!

    I am having the same problem as you @amichel86, I changed the HTTPS to HTTP parameter, but i just see an empty space appear where the widget should be.

    I installed Version 2.4.1 of Twitter Widget Pro.

    Anyone would have another suggestion?

    Thanks

  12. san4x
    Member
    Posted 1 year ago #

    Seem to have same problem here.

    WP version 3.4.1
    TWP version 2.4.1

  13. ianarmstrong
    Member
    Posted 1 year ago #

    WAMP in particular doesn't like the https:// connect option. Disable it in development and re-enable it in production.

  14. jmarteijn
    Member
    Posted 1 year ago #

    How and where can i Disable it in development and re-enable it in production?

    Thkx in advance.

  15. jmarteijn
    Member
    Posted 1 year ago #

    Has anybody got a solution to get this fixed as i would like to get this working on my website.

  16. astpaul
    Member
    Posted 1 year ago #

    Just check that you entered @xxxx for the username (and HTTP instead of HTTPS). That did the trick for me :)

  17. jmarteijn
    Member
    Posted 1 year ago #

    Tried to enter @ for the username and HTTP, but still no go!

    Any other suggestions?

  18. jmarteijn
    Member
    Posted 1 year ago #

    @FXfreelance How did you get it to work on you're site?

  19. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    Everyone:
    * Check your API usage by going into "WP Admin->Settings->Twitter Widget". Make sure to check this a few times to see how much of your API limit is being used how fast (it resets every hour, so check if the limit is used in the first 5 minutes or if it lasts all hour)
    * Check to make sure the widget has been added to a sidebar in "WP Admin->Appearance->Widgets" and that the username is in @username form in it. Feel free to screenshot your settings and paste that here
    * You can try HTTP vs HTTPS in "WP Admin->Settings->Twitter Widget"
    * Also try to "Clear Update Locks" in "WP Admin->Settings->Twitter Widget"

    Let me know how that goes and be sure to paste screenshot of the widget settings from "WP Admin->Appearance->Widgets"

  20. jmarteijn
    Member
    Posted 1 year ago #

    * API usage stays constantly the same as below:

    Current API Usage Used: 150
    Remaining: 0

    * see screenshot of the widget settings


    screenshot

    Still no Widget appears!!

    HELP

  21. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    jmarteijn: Your problem is that the widget can't talk to Twitter because you've hit your limit. The limit is 150 requests per hour, and while the widget only uses 20 per hour (one every 5 minutes), the number used is calculated based on IP so every request from your shared server (or possibly cluster of servers) is counting against that total.

    The only solutions are to ask your host to move you to a different server with fewer Twitter requests being sent (sometimes they'll do this, often they won't) or use a widget that does authentication (and log it into your Twitter account). I don't currently know of any WordPress Twitter widgets that do that. This one will eventually (I have to by March or it will stop working due to Twitter's API changes), but I don't know when exactly.

  22. elwingfield
    Member
    Posted 1 year ago #

    My twitter widget is not showing up. I find that if i disable W3 total cache it shows up but as soon as i activate W3TC it disappears. This leads me to think there is some conflict between the two plugins. If it is not a conflict between the plugin is there a setting that I need to change in W3 Total Cache to get them to play nicely. Again, when I activate W3TC the widget disappears / does not display. When I disable W3TC it works fine. Any information would help. Thank you.

  23. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    elwingfield: Completely unrelated. Please don't hijack this thread, I already answered in the thread you started.

  24. Kramarz
    Member
    Posted 1 year ago #

    There must be something terribly wrong :-)
    - fresh install (decided to give it a try to replace the old one)
    - no widget appear anywhere, no matter where I put it
    - API usage 6/150
    - cache cleared
    - switched to http
    Nothing helped. Oh well, back to my old fella then!
    Good luck with solving the issue :-)

    Nothing shows up even in source code.

  25. enduro bikes
    Member
    Posted 1 year ago #

    working fine after changing to http

  26. spennis
    Member
    Posted 1 year ago #

    Did all the things suggested, still no widget visible.

    Edit: API usage 150. Is this collective for all the sites from my web host??? If yes, this widget will never show up :P

  27. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    It's the collective for any sites on your IP. Depending on your host that could be LOTS. Unfortunately, I can't control the limit (that's imposed by Twitter)

  28. Taryn
    Member
    Posted 1 year ago #

    Hi All,
    I was having these same problems, but I wasn't hitting my limit. For me, I had my Twitter privacy settings box checked to "Protect my Tweets". I unchecked this box, and the plugin started working. In case that's anyone else's problem, thought I'd pass it along - not a plugin issue.

  29. ostermeiernet
    Member
    Posted 1 year ago #

    Hmm it´s strange. I installed the Plugin a few days ago and it work´s fine.
    Today i´ve got the Message "There´s no Tweets availible."
    I switched from https to http and i added the "@" befor my username.
    Any ideas?

    Thx, Markus

    PS:
    You can see the page with the Plugin under: http://www.ostermeier.net/twitter

  30. mejeff5
    Member
    Posted 1 year ago #

    Hi I'm having the same problem. I have done ALL OF THE THINGS the plugin author suggests, nowhere near the API limit, my tweets aren't protected, I updated to latest version, there's the @ before my screen name, HTTP rather than HTTPs, cleared the update locks,...still NO TWITTER WIDGET showing up. There's got to be something else I can do. Please help! This worked so well before, and it's only as of recently that it stopped. :(

    thanks,
    Margaret-Ellen

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.