WordPress.org

Ready to get started?Download WordPress

Forums

Cat + Tag Filter
Widget breaks category taxonomy page (4 posts)

  1. cmccarra
    Member
    Posted 1 year ago #

    Hi, I'm implementing the widget like this on a portfolio page page:

    <?php the_widget('cat_tag_filter','title=Filter Stoves:&button_title=Filter&cat_list_label=By manufacturer:&category_tax=portfolio_cats&all_cats_text=All Manufacturers&tag_list_label=Of type:&all_tags_text=Any Type'); ?>

    I am using this widget on a portfolio page to limit posts by category, once the user has selected a category they are taken to that category page but the posts don't load as I'm also loading the widget on that page. It works fine when the widget is removed from the category page. Any suggestions on what could be causing this conflict?

    Edit: The posts load if I just have:

    <?php the_widget('cat_tag_filter'); ?>

    On the category page, so it seems its just the $args that are causing the problem. Any suggestions?

    Cheers

    http://wordpress.org/extend/plugins/cat-tag-filter-widget/

  2. ajayver
    Member
    Plugin Author

    Posted 1 year ago #

    Hi!

    Try to delete arguments one by one, to understand which one of them is causing a problem. Thanks!

  3. cmccarra
    Member
    Posted 1 year ago #

    Hi, Sorry for the late reply. It is the "category_tax=portfolio_cats" tag that is causing it, any ideas why?

    Cheers!

  4. ajayver
    Member
    Plugin Author

    Posted 1 year ago #

    Hm... Not sure... Do you use a widget before or after the loop?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic