WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Why WP Multisite force /blog slug? How to remove it? (12 posts)

  1. metoo55
    Member
    Posted 2 years ago #

    I installed WP Multisite over 50 blog since WP 3.0. Every time i must delete /blog slug. I think, Why WP need default /blog slug when WP need to be CMS.

    Lastly i installed WP 3.4.1 and can't remove /blog slug, I don't know why. i try to 4 days to remove but can't do it.

    If you have solution please let me know. Thanks.

    PS. For developer please remove /blog slug default in next WordPress Multisite version. Please.

  2. metoo55
    Member
    Posted 2 years ago #

    I think i can solved it.

    1. At blog site set Settings -> Permalinks -> Common Setting -> Default (Must select default only and don't touch any thing, If you need to change category base, tag base set at Network Admin only)

    2. At Network Admin -> Sites -> (root site) Permalink Sturcture -> /%category%/%post_id%

    That it will remove /blog slug

  3. stdekker
    Member
    Posted 2 years ago #

    I believe you are right, this works.
    You are a genius!

    But you lose the structure after changing the permalinks in the sites admin dashboard. Something to keep in mind.

  4. akis
    Member
    Posted 1 year ago #

    Thank you metoo55.

  5. bransom
    Member
    Posted 1 year ago #

    Thanks -- only slight bummer left is we lose the post_name and have to live with post_id. This is still better tho, than being stuck with "/blog" in the slug.

  6. Kirk_S
    Member
    Posted 1 year ago #

    After I followed the steps from metoo55, I changed the wp-admin/network/site-settings.php to just /%postname% and it works like a dream!!!!

    As far as I can tell, everything is back to normal. This solution needs to be much more public for WordPress 3.5!

  7. Mateus Neves
    Member
    Posted 1 year ago #

    Yes, its Works. But in Network Settings when i change the permalink to /%postname% the permalink not working for my pots, but change to /%postname%/ its Work!!! Im very Happy!

  8. strategizeme
    Member
    Posted 1 year ago #

    Hello everybody, I have followed the instructions religiously....but where do you actually make the changes in the wp-admin/network/site-settings.php.

    Thank you for your support.

  9. Kirk_S
    Member
    Posted 1 year ago #

    I've got to say, I went back and tried it again a different time... can't get it to work... it seems I was pretty lucky to get it to work time #1.

    Ugh WordPress....

  10. strategizeme
    Member
    Posted 1 year ago #

    @metoo55, thank you for the handy work around. I have used postname instead.
    What about taking the category slug off so that the link reads as follow, for example:

    .com/travel/new-york-city-restaurants-tips

    Were travel is the category.

    As opposed to

    com/category/travel/new-york-city-restaurants-tips

    On a different note, Can i always revert back to default, using the slug blog ?

    What are the default permalinks setting for primary site at site level and network level?
    Apologies for the numerous questions and thank you for your support.

  11. Chrisdigital
    Member
    Posted 1 year ago #

    Thanks, confirming this works in 3.5.1

  12. CrowdfundingSites
    Member
    Posted 1 year ago #

    @metoo55, i agree with stdekker! I've been trying to fix this for over a week now. Great job, thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic