WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Why Themes do not show in admin after intalled? (11 posts)

  1. lai4444
    Member
    Posted 1 year ago #

    I have installed a few Themes on Dashboard,
    But on Manage Themes, it only show Current Theme, no any Available Themes.
    I can type the web address to change Theme like this.
    http://www.b7x24.com/wp-admin/customize.php?theme=name

    My hosting base on Linux,nginx,MySQL,PHP,Apache,
    WP is 3.4.2 version.
    wp-content was 777.

    How can i solve this problem? Pls help..

  2. justingreerbbi
    Member
    Posted 1 year ago #

    Are you using multi-site?

    If not then check permissions of your themes folder.

    - Disable all plugins and the try again if push come to shove.

  3. lai4444
    Member
    Posted 1 year ago #

    Thanks for your reply.

    No multi-site
    Permissions of themes folder is 777
    WP is new install, no any plugins yet.

  4. justingreerbbi
    Member
    Posted 1 year ago #

    Are you seeing the default theme(s)?

  5. lai4444
    Member
    Posted 1 year ago #

    i saw the default theme on beginning.But after I installed a new theme, it just show the Current Theme. no others theme.

  6. lai4444
    Member
    Posted 1 year ago #

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Re-upload a fresh, unpacked, copy of the Twenty Eleven folder to wp-content/themes using FTP or whatever file management application your host provides.
    http://wordpress.org/extend/themes/twentyeleven

  8. Mohd Rafie
    Member
    Posted 1 year ago #

    Make sure that the theme folder is in the "themes" and not in the theme folder's folder

    themes/
    ../themefolder/
    ../..index.php

    and not

    themes/
    ../themefolder/
    ../..themefolder/
    ../../index.php

    P/s: grab us a snapshot of your FTP.

  9. lai4444
    Member
    Posted 1 year ago #

    this is snapshot of my ftp,
    http://b7x24.com/tm2.jpg

  10. Mohd Rafie
    Member
    Posted 1 year ago #

    That's weird. I can access the style.css of the twentyeleven. Let me know if anyone fixed this, I am keen to know.

  11. lai4444
    Member
    Posted 1 year ago #

    I find the reason for this problem.
    Because the function scandir() is disable on my hosting.
    Edit php.ini
    on the line of disable_functions
    del, "scandir"

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.