WordPress.org

Ready to get started?Download WordPress

Forums

YOP Poll
[resolved] Why read capability? (8 posts)

  1. Hassan
    Member
    Posted 1 year ago #

    I have noticed that YOP Poll plugin requires the capability read to allow access to all of its menu items. This capability is the "weakest" one, i.e. it allows ANYONE to create/edit polls etc.

    I suggest you change it to something more appropriate like edit_pages

    http://wordpress.org/extend/plugins/yop-poll/

  2. Hassan
    Member
    Posted 1 year ago #

    In fact, you should assign different capabilities for different menu items as appropriate. For example the manage_options capability for the Options menu etc.

  3. YOP
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Hassan,

    We take account of your suggestions and implement them in the future.

    Best regards,

    YOP Team

  4. Hassan
    Member
    Posted 1 year ago #

    Thank you.

    Any ETA for the next release (4.3 I guess)?

  5. YOP
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Hassan,

    We can not give you an exact date for our next release.
    We are currently working on the new version and we still have some things to adjust.

    Best wishes,

    YOP Team

  6. Hassan
    Member
    Posted 12 months ago #

    Why not fixed in v4.3?

  7. YOP
    Member
    Plugin Author

    Posted 12 months ago #

    Hey Hassan,

    Our plugin has a separate capabilities system so "read" does not affect its security.

    Regards,

    YOP Team

  8. Hassan
    Member
    Posted 12 months ago #

    Ah, I see. Good to know.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic