WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Why is my email address showing in my blog's RSS feed? (7 posts)

  1. john.w.pitt@gmail.com
    Member
    Posted 10 months ago #

    I have an incognito blog on WP but when I pull RSS feeds from it I see that it lists me as the author of the posts using my email address. I want to suppress this, or substitute another address. I have experimented with changing Settings\General on my Dashboard, but to no avail. I suspect it may be pulling my username, since I used my email address as my username when I originally installed WP through Bluehost CPanel. I searched the Forum for this issue, but could find nothing that addresses it directly. Can anybody help?

  2. esmi
    Forum Moderator
    Posted 10 months ago #

    Did you use your email address as your username?

  3. john.w.pitt@gmail.com
    Member
    Posted 10 months ago #

    Yes, I did use my email address as my username.

    Is it the username that WP picks up as the author name in the RSS feed, even if you suppress it in the blog posts?

    What is the remedy? Start all over with a new download of WordPress to the domain? Or can you change the username?

  4. esmi
    Forum Moderator
    Posted 10 months ago #

    I suggest you set up another admin user & transfer your posts over to this new user. The log out and log back in as the new admin to delete the old admin.

  5. john.w.pitt@gmail.com
    Member
    Posted 10 months ago #

    OK, I set up another admin user.

    How do I transfer the posts?

  6. esmi
    Forum Moderator
    Posted 10 months ago #

    Edit each post and select the new user in the Author pane. If you do not see this pane, click Screen Options at the very top of the page and check "Author".

  7. john.w.pitt@gmail.com
    Member
    Posted 10 months ago #

    That works!

    Thanks for your help, Esmi.

Reply

You must log in to post.

About this Topic