WordPress.org

Ready to get started?Download WordPress

Forums

Why is my comments closed in all posts - open in all pages...!?? (45 posts)

  1. mike58
    Member
    Posted 3 years ago #

    conclusion:

    problem:
    Why is my comments closed in all posts - functions alright and is open in all pages...!??

    earlier discussion about this:
    http://wordpress.org/support/topic/comments-are-closed-i-cant-open-them-and-there-are-no-universal-settings?replies=16
    ...
    - Have Unactivated almost all my plugs, repaired the database.
    - When I change the theme the comment function is ok - so it might be themerelated...
    - Have compared and checked the comments.php and the functions.php
    (it seems to be ok agains the originals)
    - I have comments on in settings and in posts
    ...
    What could possibly be the fault here...?
    What is closing the comments on posts - but not on pages...?

    If there is any idea about the cause - and more importantly - the solution I would be very grateful.
    If there is someone who like to look at the code - we can do that.

    I have theme Forte
    blogaddress: http://mickansandelin.se/blog/

    Regards

    mike

  2. mike58
    Member
    Posted 3 years ago #

    p.s.

    I reckon there must be a fault at the comments-code where the comments are closed by the author:
    Kommentarer för ämnet i detta inlägg är avstängt av författaren
    transl:Comments for issue in this post is closed by the author

    Somewhere along this comments-closed code must the error be.

    If there is someone which can check the code the comments.php is in the pastebin below:
    http://wordpress.pastebin.ca/1949007

    Any tip appreciated...

    Kind Regards

    mike

  3. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Same problem, reported here.

    I have a question. Do you happen to be registered with Social Spark 2.0? I'm having the same problem and just realized it is happening ONLY with the two blogs that SS has access to, none of the others.

    Trying to make a connection...

  4. hmfwic
    Member
    Posted 3 years ago #

    No where can I find the answer as to WHY the comments got closed. But I did find a 'fix' for it. I have this fix in quotes because I used it and it did open up all the previously closed comments.

    That was a couple weeks ago. But I noticed that they are closed again. Anyway, here's what to do to open them back up. You have to give a SQL command in your database on your server.

    This is it:

    UPDATE wp_posts SET comment_status = REPLACE (comment_status, 'closed', 'open') WHERE post_status = 'publish' AND post_type = 'post';

  5. AlisonMooreSmith
    Member
    Posted 3 years ago #

    hmfwic, so you're saying you have the same problem? And after you reversed the comments, they reverted back to closed again?

    Augh. How I wish someone could respond to this!

  6. hmfwic
    Member
    Posted 3 years ago #

    Alison, yes. That's what happened.

  7. hmfwic
    Member
    Posted 3 years ago #

    Something just happened since two days ago. I reviewed the settings in the 'discussion' area and made sure that people could post a comment with less than two links, with only giving a name and email, registration not necessary.

    I just found a comment held for moderation with only one link in it. So I checked the settings again.

    I found that the option:
    Before a comment appears An administrator must always approve the comment WAS CHECKED.

    I KNOW that option was unchecked. And I KNOW that I didn't check it.

    Somebody has got to fix this bug.

  8. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Yes, hmfwic, that's one of the settings that is always reset in mine. Check my original thread about the bug. I have two settings that are always reset in addition to the comments all closing.

    There may be other things that I haven't noticed.

  9. hmfwic
    Member
    Posted 3 years ago #

    This is ridiculous. The settings I unchecked (above) are now checked again. AND, an old post I just looked at had the comments closed.

    Something is changing both the settings and the database fields where comments are concerned.

    I re-ran the SQL command (above) and the old post now has comments open.

    geeze

  10. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I sincerely share your frustration. This has been happening to me for over a month on TWO blogs. One of them started doing it even though it had not been updated or changed in any way for over a month.

    Very frustrating. Hoping we can find enough others with the problem to warrant having someone look at it.

  11. rjhayton
    Member
    Posted 3 years ago #

    I have a similar problem. All my old posts just turned comments off. Then I go to the discussion panel and these options were checked when I have never had it checked:

    "Users must be registered and logged in to comment "
    "An administrator must always approve the comment "

  12. rjhayton
    Member
    Posted 3 years ago #

    If I look at my posts, the "allow comments" option is not checked. So I guess I have to go through all of them and recheck that option? I never deselected it.

    And why does this just happen out of the blue????

  13. rjhayton
    Member
    Posted 3 years ago #

    The blog in question is:
    http://kjvonlydebate.com

  14. rjhayton
    Member
    Posted 3 years ago #

    Okay I'm wondering if this could be related to the host? Anyone with this issue have I-power for your host?

    Another thread said this was resolved but I'm not sure it really is. I'll see if something with the plugins caused it but I'm not hopeful.

  15. AlisonMooreSmith
    Member
    Posted 3 years ago #

    rjhayton, in my case, at least, it has nothing to do with plugins OR theme. As I've posted, I deactivated EVERY plugin, changed to a default theme, and went through the steps of repairing the database (even though there was nothing to repair) and it STILL happened.

    Very frustrating.

  16. AlisonMooreSmith
    Member
    Posted 3 years ago #

    BTW, my host for these two blogs is FatCow.

  17. Drawer
    Member
    Posted 3 years ago #

    Same thing just happened to me!!

    "Users must be registered and logged in to comment "
    "An administrator must always approve the comment "

    Were ALWAYS unchecked for me - I allow anyone to comment. And now are both checked. What could change our dashboard like this??

    Actually, the Discussion Module under each post is missing, as well. My other blogs are okay, so it's not the server. And it's not a theme, as no other theme works on this blog, either.

    I haven't added any plugins. Help?

  18. Drawer
    Member
    Posted 3 years ago #

    rjhayton, I just reread all these and I have Ipower, too. But my other blogs are okay.

    My theme is Dansette and my blog is here, if this helps: http://opedcartoons.com/.

    I think it's clear that it's a WordPress problem, since the Discussion module that appears on your screen at the bottom of every Edit Post you write (next to Blog Author, Custom Fields, etc) is totally gone. I had to go into Screen Options to make it reappear.

    My concern is why or how did all these changes happen to comments/discussion without me doing it???

    Now I'm enabling comments one by one in each post - so annoying.

  19. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Drawer, I feel your pain. :( Hope someone addresses this. HELLO?????

    Posted how to bulk edit on my original post.

  20. Drawer
    Member
    Posted 3 years ago #

    Alison, thanks, that saved me some time! And my Discussion Settings appear to be stable - no more changes that I didn't do!

    I just don't understand why this is only affecting a couple of us...

  21. AlisonMooreSmith
    Member
    Posted 3 years ago #

    Updated original post with some info. I will probably only update on that thread. Never had such a serious, lasting, unaddressed bug before.

  22. rjhayton
    Member
    Posted 3 years ago #

    I added an update to that post, too. I haven't had recurring issues but I did experience this and I don't know why.

  23. yamama87
    Member
    Posted 3 years ago #

    hiii
    i have had the same problem
    after too many trials i did what is said here
    it works well check this
    http://www.lancelhoff.com/enable-or-disable-comments-on-all-posts-in-one-step/

    all u need is to excecute 2 sql query in your database
    UPDATE posts p SET comment_status = 'closed', ping_status = 'closed' WHERE comment_status = 'open';

    and this
    UPDATE posts p SET comment_status = 'open', ping_status = 'open' WHERE comment_status = 'closed';

    read the link 4 more detailed info

    good luck :)))

  24. fusse
    Member
    Posted 3 years ago #

    Sign me up for having this very same problem.

    And I have tried to track it down in every possible way to no avail.

    And I have I-Power.

  25. hmfwic
    Member
    Posted 3 years ago #

    I'm using i-power too.

    I wonder if they're not doing some machinations to everyone's database when they mess with their version of WordPress?

    When I first installed WP, I used their tool in the control panel. Since then, I've done all the updates on my own since they are way behind on updating it on their own. Now I'm wondering if setting it up that way and updating it on my own is part of, if not, the problem?

  26. rjhayton
    Member
    Posted 3 years ago #

    Not sure that I-Power is the problem, although I've had problems with them. People on a variety of servers and using a variety of plugins and themes have reported this problem.

    This plugin helps, it's a simpler way of doing what yamama87 mentioned above. It also has an "auto" option to automatically keep comments on. It's worked for me so far:

    http://wordpress.org/extend/plugins/extended-comment-options/

  27. AlisonMooreSmith
    Member
    Posted 3 years ago #

    I have never used I-Power — don't even know what it is. And for the past many months I've upgraded within the control panel.

    Hope that info helps in weeding through the issues.

    Maybe the new version???

  28. rjhayton
    Member
    Posted 3 years ago #

    Ipower is a host

  29. fusse
    Member
    Posted 3 years ago #

    I want to find a better solution than a plugin that is just a "pain killer" for the actual problem.

  30. linusinutah
    Member
    Posted 3 years ago #

    Same problem. IPower User, but I cannot believe that this is a host related issue. While I installed using the IPower installer, I upgraded to 3.1 from WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic