WordPress.org

Ready to get started?Download WordPress

Forums

Why Doesn't My Site Work? Because of permalinks? (8 posts)

  1. PetLvr
    Member
    Posted 8 years ago #

    I've practically tried everything in the permalinks threads here
    http://wordpress.org/support/topic/54866

    I can see the front page:
    http://The-Singers.com

    I can't see any "page" or "permanent" link when you click the title of any post
    404 error. Or 500 error. or 403 error.

    It started when I changed my permalink structure to:
    /%category%/%postname%/

    it used to be setup with permalink structure of:
    /%year%/%monthnum%/%postname%/

    My goal is to end up with URL's that look something like this:
    http://the-singers.com/male-p/elvis-presley
    where male-p = category
    where elvis-presley = title of the post

    For last 36 hours I've been practically locked out of my site at times, but now - it's easy.
    - try to change permalinks
    - get locked out of my site
    - rename .htaccess to .htaccessold
    - able to access site with original problems

    I sure would appreciate concrete advise and suggestions in ways that how I can just get my site to work. i.e. permalink structures, permissions, access, etc etc... What is wrong with wordpress 2.0 ?? When will it be fixed? is there an upgrade?? (those two files didn't work - functions-post.php and classes.php)

    Thanks in advance // HART

  2. jaredquinn
    Member
    Posted 8 years ago #

    I'm getting a 500 error on your main page now.

  3. PetLvr
    Member
    Posted 8 years ago #

    THAT'S MY PROBLEM!

    But I deleted the .htaccess file once again.... so you can access (at least) the main page

  4. jaredquinn
    Member
    Posted 8 years ago #

    If you have deleted your htaccess file then your permalinks won't work - you will have to regenerate them - go to Options -> Permalinks and click the update permalink structure.

  5. PetLvr
    Member
    Posted 8 years ago #

    hi jaredquinn .. I have done that .. and, as each time I have done that I get this message:


    There is a problem with the page you are trying to reach and it cannot be displayed.

    --------------------------------------------------------------------------------

    Please try the following:

    Open the www.the-singers.com home page, and then look for links to the information you want.
    Click the Refresh button, or try again later.

    Click Search to look for information on the Internet.
    You can also see a list of related sites.

    HTTP 500 - Internal server error
    Internet Explorer

    You won't be able to access the site anymore... But by the time you read this, I will delete the .htaccess once again ... so you can see the site. Is there anything I can do? This is a viscious cycle for me.

  6. jaredquinn
    Member
    Posted 8 years ago #

    Can you post your .htaccess file once it's generated?

    Also does your hosting provider support .htaccess files? Do you know what error your web server is giving you? Do you have access to your error logs?

  7. PetLvr
    Member
    Posted 8 years ago #

    Basically .. in the error log .. it is repeating this statement, which is the last line, over and over:


    [05-Jan-2006 12:36:00] PHP Fatal error: Class 'WP_Query' not found in /home/petlvr/public_html/wp-settings.php on line 203

    The last .htaccess file that i think created
    20060107 01:35 am

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} ^feed=(feed|rdf|rss|rss2|atom)$
    RewriteRule ^(.*)$ http://feeds.feedburner.com/The-singerscom? [R]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/feed/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&monthnum=$2&day=$3&feed=$5&name=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&monthnum=$2&day=$3&feed=$5&name=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/page/?([0-9]{1,})/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&paged=$5 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)(/[0-9]+)?/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/trackback/?$ /index.php?year=$1&monthnum=$2&day=$3&tb=1&name=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)/feed/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&monthnum=$2&feed=$4&name=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&monthnum=$2&feed=$4&name=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)/page/?([0-9]{1,})/?$ /index.php?year=$1&monthnum=$2&name=$3&paged=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)(/[0-9]+)?/?$ /index.php?year=$1&monthnum=$2&name=$3&page=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)/trackback/?$ /index.php?year=$1&monthnum=$2&tb=1&name=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([^/]+)/feed/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&feed=$3&name=$2 [QSA,L]
    RewriteRule ^([0-9]{4})/([^/]+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&feed=$3&name=$2 [QSA,L]
    RewriteRule ^([0-9]{4})/([^/]+)/page/?([0-9]{1,})/?$ /index.php?year=$1&name=$2&paged=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([^/]+)(/[0-9]+)?/?$ /index.php?year=$1&name=$2&page=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([^/]+)/trackback/?$ /index.php?year=$1&tb=1&name=$2 [QSA,L]
    RewriteRule ^(.*)$ /wp-htaccess.php [L]
    </IfModule>
    # END WordPress

    The dates on the error log is when it was totally whacked and I had my server host intervened, who reported this:


    SERVER
    Posted on 06 Jan 2006 05:12 AM
    Your site is now working fine.
    If you are experiencing PHP difficluties, it may be due to permissions. Please set all permissions to 755 and remove all php flags (php variables) from the .htaccess file.

    HART
    Posted on 06 Jan 2006 05:50 PM
    Hi - I can't access the site again - did you do anything? I have done nothing with regards to FTP or permissions ... but now it shows up as HTTP 500 Internal Server error.

    SERVER
    Posted on 06 Jan 2006 06:10 PM
    Your site is working fine at the current moment.

    SERVER
    Posted on 06 Jan 2006 06:10 PM
    There was an issue with your .htaccess file. I renamed your .htaccess file in your public_html directory to .htaccess.old and you site is now accessible.
    I would double check all of the settings of the .htaccess file with WordPress.

    There's more convo back and forth, but hopefully you get the gist of things.

  8. PetLvr
    Member
    Posted 8 years ago #

    It just occurred to me // DUH // jan 5th - when it first crashed totally, I tried activating that Lucky13Apache plugin .... it was determined to be the cause of the crash (instead of fixing permalinks) BY ME guessing ... and I deleted the plugin - I had installed it back in the plugin folder, but never deactivated.... will do it now:
    /// DONE ///

    Now I'm going to try resetting the permalinks in the Options...
    /// DONE ///

    Hmm - the site is still up. /// But it's at the same point it was when I started - my permalinks do not work.

    It's set for /%category%/%postname%/

    The NEW revised .htaccess is now this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} ^feed=(feed|rdf|rss|rss2|atom)$
    RewriteRule ^(.*)$ http://feeds.feedburner.com/The-singerscom? [R]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags