WordPress.org

Ready to get started?Download WordPress

Forums

Why does WordPress add my url to my anchor text... (6 posts)

  1. DanoPano
    Member
    Posted 1 year ago #

    I have created anchor text using this code:

    If you are interested in helping others treat and prevent hypertension, consider a healthcare degree from Loyola Online Courses today!</b>

    but...

    WordPress modifies it to look like this in the page source code:

    If you are interested in helping others treat and prevent hypertension, consider a healthcare degree from Loyola Online Courses today!

    Why does WordPress add my url added to the code?

    My site is Management of Hypertension

    [ Moderator note: Please do not create anymore duplicate topics. If you need to provide an update for this problem then do so here. ]

  2. DanoPano
    Member
    Posted 1 year ago #

    To: Moderator

    Sorry for that...

    Wanted originally to clarify this topic but found that I could not edit it, therefore I created another topic for it. What if I just marked it resolved and created a revised more accurate version of it?

    As it is now, the issue is not properly defined.

    Thx,
    -Dan

  3. DanoPano
    Member
    Posted 1 year ago #

    Update on this topic:

    Simply stated, WordPress seems to automatically add my url to an anchor text I create when in fact I never included my url in the code string for the anchor text.

    I have a merchant who wants to pay for ad space on my page, Management of Hypertension
    but they don't want my url displayed in the page source as part of the anchor text code string.

    It seems, WordPress automatically addends my url to the anchor text as part of the code.

    Has anyone ever encountered this issue?

    Thanks,
    -Dan

  4. What if I just marked it resolved and created a revised more accurate version of it?

    Don't do that: you can (as you have above done so) always reply to your own topic with more details. ;)

    Duplicates make it harder for us volunteers to support you which is why duplicates sometimes get closed and/or deleted.

    but they don't want my url displayed in the page source as part of the anchor text code string.

    It really depends on how you add that. Can you provide a specific example i.e. a link? If it's an actual link to your site then of course it will be your URL. If you add the links by hand then it will be whatever link you manually put in.

  5. DanoPano
    Member
    Posted 1 year ago #

    Hi Jan,

    thanks for taking the time to explore this issue with me.

    "It really depends on how you add that. Can you provide a specific example i.e. a link? If it's an actual link to your site then of course it will be your URL. If you add the links by hand then it will be whatever link you manually put in."

    I am not sure that I have made my issue clear - judging by the quote above.

    You can see this actual situation on my page here: Management of Hypertension,

    You will find this particular ad inside the article itself. It is the graphics ad just after the subheading, 'Risk'. See the anchor text Loyola Online Courses today! The graphics also has the same link embedded inside the picture...hover till pointer converts to hand icon.

    Again, I need to remove my url from the actual code string as seen in the page source. And, I cannot find that particular url inside my html editor when trying to edit it via WP-admin's article editor. However, the url is there in the page source.

    Hope that makes more definitive.

    Thanks,
    -Dan

  6. bobfromca
    Member
    Posted 9 months ago #

    I'm with Dan... having same issue but with a text link. I add a text link on some page text using the link icon (highlight text, click link, add the http://link) - looks good in the text editor but when I view the page, WP has inserted my page URL info (minus the http://) in front of my text link - rendering link unusable. Sounds like same issue Dan is having.

    I added a text link on a page:
    <a href="http://www.kingdоmоfреtѕ.соm">Click Here</a>

    When I view the page, the link has my page link in front of my text link causing link not to work:
    howtotrainmydogvideos.com/aggression-tips/<a href="http://www.kingdоmоfреtѕ.соm">Click Here</a>

    Here is link to the page in question: http://howtotrainmydogvideos.com/aggression-tips/ links are at bottom of page (tried 3 variants - same results)

    Is there a setting I am missing to turn off so my page link does not get inserted in front of text links?

Topic Closed

This topic has been closed to new replies.

About this Topic