WordPress.org

Ready to get started?Download WordPress

Forums

Why does the sidebar gets pushed below my content on 1 author page only? (9 posts)

  1. aligajani
    Member
    Posted 1 year ago #

    I was wondering why does the Sidebar get pushed down below the content on http://www.mrgeek.me/contributors/?uid=1 where as it is all fine on the rest of the pages.

    I have tried figuring out the issue but haven't had any idea how to go on solving it. If you can see what the problem is, do let me know. I mean the code that renders the pages is all same for the rest of the authors, but why does the sidebar gets pushed below the content on my author page.

    PS: I have studied the code and it seems as on my author page (uid=1), the sidebar div is inside the content div, where as on all other pages, it isn't so and hence the ideal setup. I mean, its boggling my mind, how can it even happen. Why would the sidebar div get inside the content div only on my author/contributor page (uid=1). It's quite irritating since I am the Founder and then my page is in tatters lol.

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  3. aligajani
    Member
    Posted 1 year ago #

    That is not a very specific answer. Sorry.

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You could try the theme's support here:

    http://themify.me/forum/

    These forums only support themes from here:

    http://wordpress.org/extend/themes/

  5. aligajani
    Member
    Posted 1 year ago #

    I have contacted Themify already..they have no clue. Since it works on other uids, and not mine, it has something that the WordPress community could be of help I guess.

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Not really.

    That said, I looked at your site again and you are missing a closing div just above the sidebar div. I'd also suggest you fix the other mark-up errors as some are likely to be problematic.

  7. aligajani
    Member
    Posted 1 year ago #

    Ok it fixed mine but messed up the other uids..

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Why is that? Did you change it in the content of your page?

  9. aligajani
    Member
    Posted 1 year ago #

    I did a smart hack for now. However, I still don't get it. All other pages have 79 <div> and 78 </div> and it works fine on them. But with this uid=1 (mine), it didnt, until I balanced it now with 79 on both sides.

    <?php
    $url=$_GET['uid'];
    $ag_1 = "1";
    if ($url==$ag_1) {
    echo "</div>";
    }
    else {
    echo "";
    }
    ?>

Topic Closed

This topic has been closed to new replies.

About this Topic