WordPress.org

Ready to get started?Download WordPress

Forums

Why does my site go to some bland site map first? (4 posts)

  1. Yeong-Tae
    Member
    Posted 1 year ago #

    I am a pastor of a new church plant in Japan and I just started our first website. This is the first time I've messed with any kind of website! I bought a domain name, got WordPress, downloaded a nice theme and got the page set up. However, whenever someone tries to access my page for the first time, they type in the address (www.mitakafamicen.com) and it takes them to some bland sitemap-ish looking screen with mostly just bland links from my homepage. If you click on any of the links, then it takes you to the 'real' page. Why does it go to the empty site first? How can I fix it?

    Secondly, it might be unrelated, but every time I try to view the page, I always get an SSL error, or a message saying 'Some contents are not secure. Load page anyway?' The https is red. I called my server company, a Japanese company called Leo Server, and they told me that there was nothing I could do about it since I was using my own domain name and I would need branch my website directly off of their sites to get a green https, but that it would change my URL to include some of their stuff (sorry, not familiar with internet terms).

    Is there any other way I can make my site secure so that I don't have warnings and red https symbols anymore?

  2. Harrison O.
    Member
    Posted 1 year ago #

    The SSL is a security certificate that you can add to your domain to make it more secure. The thing is that you don't need to secure your whole site. that is used more on pages that contain payment forms, etc...
    You can note that your url shows https: which the "s" means is secure. The first time arriving at your site is http://www.mitakafamicen.com/ (without the "s") and that is why the page is showing like that, the style.css doesn't load because it was installed on the https://
    http://www.mitakafamicen.com/
    https://www.mitakafamicen.com/

    I recommend you removing the SSL certificate from the domain.
    You'll need to login to the dashboard, go to settings > general and change the wordpress address URL and site address url. (change https:// to htpp://). Be careful while updating this area. Any mistake, you will need an FTP software or login to your cpanel to fix it.

    Removing the SSL will also solve the problem with the "secure certificate message". If you don't remove that, then everyone will keep getting that message.

  3. Yeong-Tae
    Member
    Posted 1 year ago #

    Thank you so much for the information! You're a lifesaver! So fixing my URL will resolve both problems? What a relief!

    Let me just make sure though. You said,

    'https:// to htpp://' - You meant http://, not htpp:// right? In other words, I only need to remove the 's' right?

    Thank you so much!!

    -Yeong-Tae

  4. Harrison O.
    Member
    Posted 1 year ago #

    Sorry, there was a typo there.
    you should change from https:// to http://
    Basically, you just need to remove the "s".

    If anything goes wrong, you may need to use the methods on this page to get the site working again: http://codex.wordpress.org/Changing_The_Site_URL

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.