WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Why do all my dynamic links begin with HTTPS? (6 posts)

  1. frontdesk
    Member
    Posted 4 years ago #

    I have been attempting to tweak my WP site to only generate HTTPS for certain pages by uploading a special .htaccess file into my root directory.

    Having no complete success so far I decided to back out my .htaccess file for the time being (which I did, so now I am running with NO .htaccess file at all).

    My problem is that - even though I have no .htaccess file and no SSL-oriented plugins installed - my site continues to generate HTTPS for all of my navigation links.

    What is causing my WP to continue to generate HTTPS nav links even though I have no .htaccess file?

  2. Mark / t31os
    Moderator
    Posted 4 years ago #

    The URL configured in the settings at a guess?

  3. pcmehrdad
    Member
    Posted 4 years ago #

    remove
    define('FORCE_SSL_ADMIN', true);

    from your wp-config.php file!
    or a line like that contain ssl !

  4. frontdesk
    Member
    Posted 4 years ago #

    DOH moment on my part. t3los_ you were correct and it was simply the URL settings in my dashboard. Thanks

  5. Mark / t31os
    Moderator
    Posted 4 years ago #

    Happy to hear you've fixed the problem and thanks for posting back to let us know... ;)

  6. Grubbyseismic
    Member
    Posted 3 years ago #

    I'm having major problems getting FORCE_SSL_ADMIN to work.

    The define statement is waaaay up the page (wp-config.php) and yet the login process stops at wp-login.php.

    Server setup problem? ssl_module is loaded...

Topic Closed

This topic has been closed to new replies.

About this Topic