WordPress.org

Ready to get started?Download WordPress

Forums

Why did my links break? (4 posts)

  1. Matt
    Member
    Posted 6 years ago #

    http://www.nwmusicblog.com/page/2/ shows the same thing as http://www.nwmusicblog.com

    And my tag cloud's links are broken too, for instance, http://www.nwmusicblog.com/tag/beastie-boys/ throws a "Sorry, no posts matched your criteria."

    Is it peramalinks/mod-rewrite?

    WordPress address is http://www.nwmusicblog.com/blog
    Blog address is http://www.nwmusicblog.com
    .htaccess is at the site root, and looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  2. Matt
    Member
    Posted 6 years ago #

    This is driving me nuts.

    I just tried the default template, and its links work, so it's something with my template.

    The strange thing is both templates' create the same links...

    http://www.nwmusicblog.com/page/2/

    ... it's just that in my template it just defaults to the index page instead of showing "page 2". Grr.

  3. Matt
    Member
    Posted 6 years ago #

    Right now I'm thinking putting the virgin template back in and recreating all my changes. Yuk.

  4. Matt
    Member
    Posted 6 years ago #

    Found it. I had

    if (is_home()) {
    	query_posts('cat=-3');
    }

    on my index page. That kills your nav, FYI.

    Now I have to figure out another way to exclude category 3 posts.

Topic Closed

This topic has been closed to new replies.

About this Topic