WordPress.org

Ready to get started?Download WordPress

Forums

Why are widgets frozen in the back end? I can't modify them. (10 posts)

  1. trusktr
    Member
    Posted 3 years ago #

    I can't modify the settings of any of my widgets in the back end. I can't expand them. I can't drag them. I can't do anything!

    I just upgraded to 3.0.5 too.

    What's going on?

  2. tessey
    Member
    Posted 3 years ago #

    Its odd, I have one site 3.0.5 where the widgets works and 2 where they don't. The second one has no addons and original template. Would love to know what is causing the problem before I spend more time on everything else.

  3. trusktr
    Member
    Posted 3 years ago #

    Yeah, it's getting annoying! I can't do anything to my sidebar!

  4. dragonc
    Member
    Posted 3 years ago #

    There's bug. One answer given was to upgrade akismet which has a fix for the 3.0.5 bug. I haven't tried it as I reverted back to the previous version. I won't upgrade until 3.5 appears.

  5. trusktr
    Member
    Posted 3 years ago #

    I tried updating Akismet, but that didn't fix it. :(

  6. trusktr
    Member
    Posted 3 years ago #

    I tried updating almost all my plugins but the widget editing functionality is still broken.

    I want to modify my widgets, please WordPress! Fix this.

    What's even worst is that if I upgrade one of my plugins that some widgets rely on, then the individual settings will have to be redone, but that's not possible with the current un-editable state!

  7. Ryan Boren
    WordPress Dev
    Posted 3 years ago #

  8. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    Per #16508, one user was accidentally overriding an important JavaScript file. It wasn't 3.0.5.

    So that said, please switch to the default theme briefly, and see if that fixes it. If it does, let us know what theme you're using, and we can try to diagnose the JavaScript enqueueing issue. If it doesn't, then please deactivate plugins one by one.

    If you recently updated a plugin or theme, this is a far more likely than core. We didn't go anywhere near widgets in 3.0.5.

  9. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

  10. trusktr
    Member
    Posted 3 years ago #

    Thanks for the link Andrew. I have wordpress 1.5 and for some reason (as i've explained in the link to bug #16508) it all of a sudden started working today, and I haven't done anything.

    I know it's not the theme because it was working before with the same theme, and also it's not any plugins because i've deativated them all and the problem persisted.

    So wierd! I wish i knew what info to give you to help, but i have no idea what's causing the behavior...

    If it happens again i'll keep you posted.

Topic Closed

This topic has been closed to new replies.

About this Topic