WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Why all my pages and in-page links are nofollow? (9 posts)

  1. Aahan Krish
    Member
    Posted 3 years ago #

    I see <meta name="robots" content="index, nofollow" /> on all pages & posts except the homepage of my website at http://wwwery.com

    This happens why I choose "I would like my site to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers" in the Privacy Settings.

    That line gets removed when I choose "I would like to block search engines, but allow normal visitors". Why is it happening the reverse way?

    Somebody please help and suggest.

  2. Your site doesn't load for me.

    Check your header.php file and see if that's listed in there. I only see no-follows on links in my comments section which is as designed for that site.

  3. Aahan Krish
    Member
    Posted 3 years ago #

    What? my site doesn't load there??? Why? it's loading fine here. I have checked my header. All's normal. I don't know how it happened, but when I disable search engine access in privacy settings all is fine. But once i enable "I would like my site to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers," my header shows <meta name="robots" content="index, nofollow" />

    My site should load fine. Please see if all's crawlable for search engine and all is as it should be.

  4. It times out when I try and access it. Dunno why. Could be distance. It's working now.

    But once i enable "I would like my site to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers," my header shows <meta name="robots" content="index, nofollow" />

    That seems backwards.

    Right now I see this:
    <meta name="robots" content="index,follow,noodp,noydir" />

    What plugins are you running?

  5. Aahan Krish
    Member
    Posted 3 years ago #

    So <meta name="robots" content="index,follow,noodp,noydir" /> means that it's fine?

    Anyway. These are the plugins that i use at present: akismet, category-posts, delete-revision, digg-digg, expand-text, google-sitemap-generator, gregs-high-performance-seo, hyper-cache, intensedebate, nextgen-gallery, related-posts-by-category, si-contact-form, stats, syntaxhighlighter, tinymce-advanced, user-locker, user-switching, wp-no-category-base, wp-noexternallinks, wp-polls, wptouch-pro

    Please stay on the post. I will too. So that we can finish it quickly. Thanks.

  6. I don't see that meta for robots on any site I'm running so ... I'm really not sure.

    wp-noexternallinks would be MY guess as to why it's happening, based on the documentation: http://wordpress.org/extend/plugins/wp-noexternallinks/

  7. Aahan Krish
    Member
    Posted 3 years ago #

    Hi, I just read this. http://www.theitechblog.com/1016/what-are-noodp-noydir-meta-tags-why-used-seo and it seems that the

    <meta name="robots" content="index,follow,noodp,noydir" />
    is for good. What do you say?

  8. I think they're fine, but I don't know why you're getting them backwards, the way you are. I think THAT is caused by a plugin.

  9. Aahan Krish
    Member
    Posted 3 years ago #

    Anyways, as long as it's fine... I'm happy. Thanks for the support Ipstenu.

Topic Closed

This topic has been closed to new replies.

About this Topic