WordPress.org

Ready to get started?Download WordPress

Forums

[closed] White text / invisible text in visual editor on admin panel (10 posts)

  1. markmanx
    Member
    Posted 3 years ago #

    I had this problem after installing a clean version of WordPress, most of the fixes I found ask you to deactivate plugins or delete and reinstall entire directories, but there is a simple CSS fix for this.

    By default the text color is set to white, so you just need to change the CSS code to set it to black. FTP into your WordPress installation and go to wp-admin > css, and open up wp-admin.css in a text editor. Search for the text "theEditor". Change the color value to black.

    Refresh your browser (make sure that you're not loading the page from the cache, to do this on Firefox and Safari click refresh while pressing shift to properly reload the page). You should be able to see text now.

  2. junkcollector
    Member
    Posted 3 years ago #

    This problem occurred for me sometime within the last month on a what was previously a perfectly working WP site. I followed the advice on another post and re-uploaded the wp-includes directory and that solved the problem.

    I had not made any changes to the site, but I did see a few user registrations in since it had last worked. I am wondering if someone intentionally altered my site through a vulnerability.

    BTW - that was a WP 2.9.2 site.

  3. Femi
    Member
    Posted 2 years ago #

    Apologies for reviving a long-dead entry, but I wanted to ensure that anyone coming up on this while searching for a fix for the white text on white background would see this (as this is the second entry in Google for "white text in wordpress editor". The problem for me was the PS Disable Autoformatting plugin: in the file /wp-content/plugins/ps-disable-auto-formatting/js/280/ps_editor.js it sets the color to white, among a bunch of other unexplainable things. If you edit that file and comment out the line that looks like this:

    $('#content').css('color', 'white');

    you should be all set.

  4. Doug Nix
    Member
    Posted 2 years ago #

    I have this same issue, and I have looked for both the ".js .theEditor" fix and the "ps-disable-auto-formatting" issue, and neither appears to be the case.

    If I highlight all text in Visual Mode, I can see that the HTML tags are all showing as well.

    I am running WP 3.3 and have not had this issue up until this release. I have not changed any plugins since.

    Another, perhaps related, symptom is that all of my TinyMCE editor buttons have disappeared.

  5. joero4ri
    Member
    Posted 2 years ago #

    I'm having the same problem with 3.3.1 after upgrade.

  6. joero4ri
    Member
    Posted 2 years ago #

    I just fixed my problem it was related to failed plugin update which I was ignoring. I re-ran the update, and it installed fine. Now my text and buttons came back. It was the Subscribe 2 plugin, which has a tinymce button, so maybe that was why the buttons disappeared.

  7. barryha
    Member
    Posted 2 years ago #

    I think I just fixed the same problem in my WordPress 3.3.1 installation.
    I edited CSS in /wp-includes/css/editor-buttons.css.
    From: .js .tmce-active .wp-editor-area{color:white;}
    To: .js .tmce-active .wp-editor-area{color:black; /* bwh */}

    This problem has been a little strange in the sense it is inconsistent. The visual page editor worked fine to create several pages, and then I came back a few days later and text was invisible (white on white). I deleted all my plugins, restored the original WP 3.3 files, and used the default theme, all without success. Then, thanks to Firefox extensions I found a fixable CSS control, but since the original CSS file never changed, I think I'm just masking another ugly problem elsewhere.

    Anyway, I hope this helps someone else, too. ~Barry~

  8. gusrounick
    Member
    Posted 2 years ago #

    I'm having the same problem. Invisible text but with coding in Visual Editor which is very strange. I tried the solutions except for editing CSS which I do not know how to do. :( Firefox crashes on my comp.

    I use studio press genesis framework. I dont know if that is the source if people above are using as well.

    Please let me know if someone comes up with a solution for the root cause.

    Thank you!!!

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    Please post your own topic.

  10. barryha
    Member
    Posted 2 years ago #

    @gusrounick If you have access to the folders in which WordPress is installed, then look for the file /wp-includes/css/editor-buttons.css

    1. Edit the file 'editor-buttons.css'
    2. look for the text ".js .tmce-active .wp-editor-area{color:white;}"
    3. change the stuff inside the curly braces from "color:white" to "color:black"

    I can't help with firefox not working; firefox was only mentioned as just one possible route to figuring out which file to edit. But now ya know the file name, so commence hacking. ;-)
    My situation was on a self-hosted bog-standard vanilla WordPress 3.3.1 clean installation for a new domain name.
    For me, things are working better since I added the line "define('CONCATENATE_SCRIPTS',false);" to the main WordPress configuration file (wp-config). But this is a band-aid that masks problems in loading scripts, not a real or long-term fix.
    Good luck, Barry

Topic Closed

This topic has been closed to new replies.

About this Topic