WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
[resolved] White Space Appearing before Link Library (7 posts)

  1. offthepage
    Member
    Posted 2 years ago #

    Hi,

    I'm loving the Link Library plugin! However, I have a strange formatting issue. My list has a large white space inserted above it.

    I've worked out, that the size of the space, depends entirely on how many links I have set to appear per page.

    For example,if I have Links per Page set to '5' there are 5 blank paragraphs appearing between the title and the links table. If I have Links per Page set to '15', then 15 blank paragraphs appear between the title and links table).

    Has anyone else seen this, or can anyone provide a tip on how this might be fixed?

    You can see the issue here: http://methlabcleanup.jdlearnonline.com.au/255-2/

    Thanks!

    http://wordpress.org/extend/plugins/link-library/

  2. Yannick Lefebvre
    Member
    Plugin Author

    Posted 2 years ago #

    You seem to have a field selected for display that does not contain any data, and that is getting rendered outside the table. Can you post a screenshot to your link sub-field configuration table?

  3. offthepage
    Member
    Posted 2 years ago #

    Thanks for your help Yannick, have loaded a screenshot of the sub-field table here:
    http://methlabcleanup.jdlearnonline.com.au/files/Capture.jpg

  4. Yannick Lefebvre
    Member
    Plugin Author

    Posted 2 years ago #

    Try removing the checkbox for Link Description. Since it is checked but does not have table code showing up before and after the item, the link descriptions all end up landing above the table.

  5. offthepage
    Member
    Posted 2 years ago #

    All that does is remove the description from each entry. The large white space remains up the top.

  6. offthepage
    Member
    Posted 2 years ago #

    I took out the image (as it was loading the image from the home page of sites, rather than the particular URL) so no longer needed the table layout. Took out all the table layout elements, and have lost the white space issue.
    But I wonder if this is an issue? For others using tables I mean?
    Not me - I'm all good now. Thanks for your help!

  7. Yannick Lefebvre
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, I see. The problem was probably that you were display a data field that contained no data and forgot to put <td> and </td> tags around that field. These would end up before the table.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic