WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] White Screen With upgrade.php (9 posts)

  1. ChrisH
    Member
    Posted 6 years ago #

    I'm trying to upgrade to the latest release of WP (2.2), and I seem to have done everything right --

    Turned off the plugins - check
    Erased and replaced files - check

    But when I try to run upgrade.php, all I get is a blank white page. Anyone know what's happening here and how to get around it? I've tried this several times, and I'm at my wits' end.

  2. Samuel B
    moderator
    Posted 6 years ago #

    Does install.php tell you your blog is already installed?

  3. ChrisH
    Member
    Posted 6 years ago #

    No, it tells me nothing. When I run the page, all I get is a big blank page.

  4. iscifi
    Member
    Posted 6 years ago #

    ChrisH

    I have seen this a ton of times and is either lack of memory allocated on the web server for PHP scripts, or a chmod issue where the web server cant read/execute to the directory.

    first things first make sure your directories have a chmod of 755.

    Then find out if your php.ini file on the webhost has been setup for 16MB of memory or more. FYI the default is only 8MB you webhost can help with that.

    if you want to know what your memory allocation is , this script will dump a ton of php info to your browswer

    <?php
    phpinfo();
    ?>

    Good luck

  5. ChrisH
    Member
    Posted 6 years ago #

    Thanks very much, iscifi. I'll check it out. Even if it doesn't work, thank you. At least I don't feel crazy now.

  6. ChrisH
    Member
    Posted 6 years ago #

    Update: Again, thanks for the help. It turns out, though, that it was neither of these issues. The template I was using was a variation of K2 (TripleK2); apparently it was mucking up the script, presumably because of the conflict between Sidebar Modules and the new integration of widgets into the core. I'm using the default layout now, and I'll have to play with the template a bit before I can get back to normal.

  7. hugoboss
    Member
    Posted 6 years ago #

    Hello!

    I experiencing the same error installing 2.31!
    The upgrade.php looks ok but firefox presents it as a downloadable file, it will not run!
    I have looked through most of the other posts conc this problem.
    The rights are set up ok and my memory allocation should be large enough!
    Pleas help!
    regards,
    Hugo

  8. hugoboss
    Member
    Posted 6 years ago #

    I changed the maximum script execution time on my server and the maximum HTTP POST size. I am not sure if these are correct parameters to change, but I got it working upgrade went smooth!

  9. Paul McGuinness
    Member
    Posted 6 years ago #

    I can confirm that creating a file called .htaccess in the WordPress folder with the single line:-

    php_value memory_limit 16M

    Fixed it for me!

    This is useful if you are on a shared server and the ISP doesn't want to change PHP.INI settings (mention no names... Fasthosts!)

Topic Closed

This topic has been closed to new replies.

About this Topic