WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] White screen of death upon switching to my custom theme (9 posts)

  1. Lillymon
    Member
    Posted 3 years ago #

    Hello!
    Before starting I know there are many threads here describing the same problem, I went through all of them and unfortunately, none of the solutions offered there worked for me. I hope someone will be able to help me out with my problem.

    I've recently got WP 3.0.1 up and running on my server. Everything was fine until I switched to a certain theme I had been planning on using.

    This is the problematic custom theme
    that I want to use. It's a free theme made by paddsolutions.com which I've modified. I tested the theme in my localhost and it works perfectly fine but as soon as I activate it on my server, my dashboard goes blank along with the entire site. I figured the cause could be due to an error on my part so just to make sure of this, I installed the original unmodified version of this theme but even the unmoded version caused my site to go blank. I tried contacting the theme creator regarding this issue, but he is not answering.

    I've googled a lot about this issue, turns out it's very common and most people figured out how to solve it.
    I deactivated my plugins, disabled all javascript, both inline and imported, checked for extra lines in my config, setting and theme function files, checked my .htaccess file, reuploaded WP's core files but nothing seems to work. I've revised the codes so many times but I can't find out what's causing the problem.

    Some of you might suggest I simply switch to another theme and be done with the problem, but I really don't want to if there is a way to solve it. I have spent a lot of time modifying the above linked theme to suit my needs and I like it very much. I'd like to try everything to fix it before I decide it's time to move on to a new one.

    Could someone please test it for me or look through the files to see what's wrong ? Any suggestions is greatly appreciated.

    Thank you very much for your time.

  2. jduffell
    Member
    Posted 3 years ago #

    I've only glanced at your theme files however depending on your blog setup you may need a file called front-page.php

    Just try duplicating index.php and renaming it to front-page.php

    Reactivate the theme and give that a whirl

  3. Lillymon
    Member
    Posted 3 years ago #

    Hello jdufell,
    I duplicated index.php, renamed it as front-page.pho & activated the theme again but the site still goes blank as soon as I applied it =(

  4. jduffell
    Member
    Posted 3 years ago #

    hmmm, couldn't really say what's occurring there, I installed it on my site and it worked straight away.

  5. Lillymon
    Member
    Posted 3 years ago #

    wow! just knowing that it worked with someone else gives me hope. I'll continue looking for the error, at least, now I know that the theme is fine.

    Could permissions cause the blank screen ? It's the only thing I haven't checked yet.

  6. Samuel B
    moderator
    Posted 3 years ago #

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 128M:
    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)
    
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 128M
    
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '128M');

    try option 3 - it's the easiest

  7. Lillymon
    Member
    Posted 3 years ago #

    I tried option 3 but nothing has changed. Site still goes blank when I apply the theme :(

  8. Derek Fox
    Member
    Posted 3 years ago #

    I would suggest that you turn off all your plug-ins. From time to time when you have a ton of plug-ins turned on with a new theme it can cause issues.

    Then I would go about adding the plug-ins back one at a time. To see if that fixes the issues.

    It is worth a try.

    Derek
    [sig moderated as per the Forum Rules]

  9. Lillymon
    Member
    Posted 3 years ago #

    I've solved the issue, my theme works fine now.
    Turned out my server was using php4, I changed it to php5 and the white screen disappeared. Just in case someone else had the same problem and wanted to try doing the same.

    Thank you everyone for your time and help. Much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic