WordPress.org

Ready to get started?Download WordPress

Forums

NS Cloner - Site Copier
[resolved] white screen (2 posts)

  1. Rustica
    Member
    Posted 9 months ago #

    Hello,
    I tried to clone my main site but i still have a white screen even if the max_execution_time has been increased. Could you help please?

    http://wordpress.org/plugins/ns-cloner-site-copier/

  2. Never Settle
    Member
    Plugin Author

    Posted 9 months ago #

    Some possibilities:

    1) The actual max_execution_time value being used at runtime did not increase. We have seen hosts say they raised this and/or we've changed this value in php.ini or another place, but global defaults for PHP are still overriding it somewhere else. Did you physically time the clone operation? How long is it actually running from the time you click Clone Away to the time you get the white screen? The logs are also date / time stamped so you can tell exactly how long it ran by the first entry to the last.

    2) The new higher value of max_execution_time is still not enough. Try timing it with a stopwatch to see what setting is actually in effect. If it's the amount of time you expect, raise the limit and try again. If it's not the amount you think you have set then figure out where to change the active setting.

    3) You can try disabling the timeout altogether by editing the plugin code just inside the line
    function admin_init() {
    try adding the line
    set_time_limit(0);
    so that it looks like:

    function admin_init() {
        set_time_limit(0);
        ...
    }

    That might work, but sometimes environments don't honor setting it on the fly from PHP like that. Depending on your version that code might already be in the Cloner.

    4) Clean your database before cloning. You can use one of the great DB cleaner plugins for WP that are out there. If there are a lot of post versions, auto-saves, transients and other DB clutter that will slow down the cloning and will be eating unnecessary time in the cloning process. Plus it will just copy that DB garbage to the new site as well, doubling the clutter and performance penalties. Make sure you clean (delete unnecessary data) and crunch (optimize) the DB. You should also make sure that any orphaned tables (like from inactive or removed plugins that left them in the DB) are manually deleted before optimization and cloning.

    5) If you still aren't having success you can always send us your logs via http://neversettle.it/support-and-feedback/ that the cloner captures in its /logs directory and we'll take a closer look.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.