WordPress.org

Ready to get started?Download WordPress

Forums

Expound
[resolved] Where's the rest of my post? (29 posts)

  1. mitspanner
    Member
    Posted 6 months ago #

    So I've just installed expound. I've got two pages, The homepage and one other. I make a blog post and it shows up on the homepage, But only the first few lines followed by a button marked "continue reading". The problem is that the button directs right back to the same page, The homepage. Where's the rest of the post?

  2. fridakarlin
    Member
    Posted 6 months ago #

    I have the same problem. When I press the "Continue reading" it´s linked to the page that I´m already in. So I can´t read the hole post.

    And the post shows in a weird way. First it shows the most recently written post with a "continue reading" button, then four posts end up in a row horizontally, and then the rest of the posts shows as normal under that.
    I want all my posts to show the hole content as a normal blog. Is that possible?

    Here you can see the page: peterstromberg.se/wordpress/nyheter

  3. WPyogi
    Volunteer Moderator
    Posted 6 months ago #

    See:

    http://wordpress.org/support/topic/featured-post-up-top-then-four-post-row?replies=18

    This is from WordPress.COM, but I think it provides the general set-up instructions that should be the same:

    http://theme.wordpress.com/themes/expound/

  4. mitspanner
    Member
    Posted 6 months ago #

    None of that helps me. Still the same problem:

    I've got two pages, The homepage and one other. I make a blog post and it shows up on the homepage, but only the first few lines followed by a button marked "continue reading". The problem is that the button directs right back to the same page, The homepage. Where's the rest of the post?

    BTW- Under "Pages>All Pages" I have just one page named "about" with this url "http://localhost:8888/wordpress_FUPsite/about/"

    My home page has this url "http://localhost:8888/wordpress_FUPsite/"

    screenshot http://i.imgur.com/DDrFoVV.jpg

  5. mitspanner
    Member
    Posted 6 months ago #

    I added an image to the post. No luck. Still have just the summary on the front page with the button just links to the summary on the same page.

  6. mitspanner
    Member
    Posted 6 months ago #

    Okay, I threw out all my pages and menus, but a homepage still displays at the url "http://localhost:8888/wordpress_FUPsite/". So why doesn't this "homepage" show up in the dashboard at ">Pages>All Pges"?

  7. mitspanner
    Member
    Posted 6 months ago #

    I switched over to the theme Twenty Fourteen. Now all the problems I listed above are gone. It's just really ugly out-of-the-box :-(

  8. fridakarlin
    Member
    Posted 6 months ago #

    I have still problem with my posts. When I click on Continue reading it links to the same page so I can´t read the hole post. How do I fix that?

  9. vanessajw
    Member
    Posted 6 months ago #

    create a new page, call it 'posts' but leave it blank. Then go back to your dashboard-settings-reading, click on the reading then you'll see some choices about whether you show your lists of posts. Create a few and you'll see that you can choose what content page you use for 'home' and which page for 'posts'. it's easier at the start to create a new blank page with some blurb about you, call it 'home' for example.

    I don't use the auto one called 'about'. Just create two pages, a one about you, call it home say, and a blank page just called 'posts' and then go to the settings-reading page and select the down arrow, front page shows 'static page' and you can then select which static page you've made e.g. one about you....and then another page for the posts....experiment and you'll see. Continue reading link will only link back to the page that your posts is already set to display which maybe already the 'home' or 'about' page. But create some new blank pages called home and posts and you'll see more options. Then the posts will display one under the other on the posts page in a brief form and then you click in further or 'continue reading' to read the whole post.

  10. vanessajw
    Member
    Posted 6 months ago #

    ps remember to add the posts page into your menus controls and click the tick to add it to your menu design. see dashboard-appearance-menu, then tick your 'posts' page to 'add to menu' and you see you can then drag it around to place it where you want on your menu bar.

  11. mitspanner
    Member
    Posted 6 months ago #

    @vanessajw thanks for your help. I still have problems though. Expound seems to generate a "Front" page automatically which doesn't show up on the dashboard under"Pages" and this is where my posts display as summaries only. These summaries then link right back to the same "Front" page. I tried adjusting the "reading" settings which results in multiple Pages with summaries but still no complete blog posts.

  12. vanessajw
    Member
    Posted 6 months ago #

    can you see your posts in your dashboard and edit them in full there? They must be somewhere in full?

  13. mitspanner
    Member
    Posted 6 months ago #

    @vanessajw thanks for your help.

    Okay, So my posts are appearing on my homepage as summaries. When I edit posts I can see that "slugs" have been generated. So where is the page that the slug is pointing to? The headlines of the posts on the front page only link back to the front page. So how do I end up with pages for my posts, each post? And how do I get the summaries to link to the post page?

  14. mitspanner
    Member
    Posted 6 months ago #

    Sorry I can't point you to my website because I'm working on a local server.

  15. mitspanner
    Member
    Posted 6 months ago #

    Do I have to manually make a page for each post? And if so, how do I get the post summaries to link to that page?

  16. vanessajw
    Member
    Posted 6 months ago #

    I don't know what slugs are. But when you write your post, in the edit window, just above is a blue button saying 'view page' or presumably post, try clicking that and see where the full post shows up. If it's full at all, it will show up.

    Make a blank 'page' (not post) call it/title it 'posts' or whatever e.g. say 'news' and then point your settings to show your 'posts' to that page, yes they will show a summary list, click each entry title and you should show the whole post! it must be somewhere. Unless your posts are very short but even then it should show up on a lone page with probably a lot space round it.

  17. vanessajw
    Member
    Posted 6 months ago #

    read this bit, this is what I'm talking about.

    http://codex.wordpress.org/Settings_Reading_Screen

  18. vanessajw
    Member
    Posted 6 months ago #

    http://codex.wordpress.org/Settings_Reading_Screen

    read this, you have to create a posts page, a blank page with no content, but write in the title 'posts' or news or whatever you want. Don't use front or home page, it's confusing things.

  19. vanessajw
    Member
    Posted 6 months ago #

    make the front page a static page, with something on it, then you can see the difference between your static 'home' page and your post page.

  20. vanessajw
    Member
    Posted 6 months ago #

    having done that checking the menu structure would help. Make a new menu, called it say menu2 and tick which pages you want from the left small list, which will then appear in the main menu on the right side. Then you can drag the menu names around into the order you want. Then click in all your settings that menu2 is being used. Again I find the auto setup in themes is confusing so I tend to create my own pieces to make it obvious which bits I want it to use.

  21. vanessajw
    Member
    Posted 6 months ago #

    try this.

  22. vanessajw
    Member
    Posted 6 months ago #

    try this....

    <a href="http://codex.wordpress.org/WordPress_Menu_User_Guide"></a>

  23. vanessajw
    Member
    Posted 6 months ago #

    http://codex.wordpress.org/WordPress_Menu_User_Guide

    [Moderator Note: Please ensure that you are embedding links correctly in your posts.]

  24. vanessajw
    Member
    Posted 6 months ago #

    http://codex.wordpress.org/WordPress_Menu_User_Guide

    [Moderator Note: Please ensure that you are embedding links correctly in your posts.]

  25. mitspanner
    Member
    Posted 6 months ago #

    Vanessa, you've done A yeoman's job to try to help me, and I thank you, but it's not working. I read all the stuff you're pointing me to but I still don't see anything that relates to my issues.

    I want my posts to appear on my FrontPage.

    And for simplicity, I'm thinking I want the front page to be at the URL:
    "http://localhost:8888/wordpress_XXXXsite/" not the extended url
    "http://localhost:8888/wordpress_XXXXsite/some-name"

    So the problem I'm wrestling with now is that my posts appear as summaries even though I have them set to appear as full text in the "Readings Settings"

    and

    I can't modify the URL of my post's heading link to point any other page that I might create to host full text of the post.

  26. mitspanner
    Member
    Posted 6 months ago #

    I'm a WordPress newb and this is happening not only in the Expound theme, but in other themes as well. So I and I'm thinking that I am missing something basic.

  27. mitspanner
    Member
    Posted 6 months ago #

    Eureka! I discovered that I needed to go into the "Settings>Permalinks>Permalink Settings" where it had been set for a "custom structure" with no designation for that structure. Whew! Now I have post summaries on my front page that are linked to pages which display the full post.

  28. vanessajw
    Member
    Posted 6 months ago #

    at last well done ,I was about to mention permalinks.....Anyway well done for studying more....it's a learning curve which is ever upwards I find!

  29. fridakarlin
    Member
    Posted 6 months ago #

    THANK YOU mitspanner changing Permalink Settings solved my problem too! :D

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.