WordPress.org

Ready to get started?Download WordPress

Forums

Posts in Page
[resolved] Where to place shortcodes? (7 posts)

  1. Chris_Page
    Member
    Posted 1 year ago #

    Hi - I've downloaded the plug-in, activated it in my plug-ins, but when I enter the shortcode in a page, either in the html or visual, it doesn't add anything to the page once saved - the short code itself doesn't display as text, it just appears blank.

    I was trying to mix shortcodes - i.e. [ic_add_posts category='category-slug1,category-slug2' showposts='5'].

    But I tried to just change it back to show just one category with no number limit and it still won't display. What am I doing wrong?!

    http://wordpress.org/extend/plugins/posts-in-page/

  2. Eric Amundson
    Volunteer Moderator
    Plugin Author

    Posted 1 year ago #

    Hey Chris,

    What happens when you just use the base shortcode with no additions, like: [ic_add_posts] ? Can you get it to display at all?

  3. Chris_Page
    Member
    Posted 1 year ago #

    Hey Eric - cheers for the response.

    I tried what you suggested, and it worked. Let me now sheepishly admit I was actually adding tag slugs to the category short code... D'oh!

    However...!

    I have now changed the code to tag, with only one tag selected - but is now showing all tags still.

    The site is:
    http://walkforareason.co.uk/find-your-challenge/
    The post stream at the bottom shows how the short code [ic_add_posts tag='bagging-list'] is actually displaying posts without that tag. (Ignore that the posts don't have content and that everything is basic - I'm just playing with form at the minute!)

    Best wishes

    Chris

  4. Eric Amundson
    Volunteer Moderator
    Plugin Author

    Posted 1 year ago #

    Howdy Chris,

    I'm sure I tested this, but we're looking into it now on a testbed to see if we can reproduce.

    I'm wondering if you might have categories or other taxonomies setup to use the same slug?

    Anyway, we'll test and get back to you shortly.

    Eric

  5. Eric Amundson
    Volunteer Moderator
    Plugin Author

    Posted 1 year ago #

    Hey Chris,

    I just tested the latest version of Posts in Page on my testbed using tags and categories, both independently and together and am not having any issues. It's pulling by the tag just fine.

    Would you do me a favor and:

    1. Make sure you're using the latest version
    2. Create a new bogus tag, apply it to one or two posts, and then let us know what happens?

    On my testbed, I use 'junktag' or something obviously full of bogosity. :)

    Eric

  6. Chris_Page
    Member
    Posted 1 year ago #

    Hey Eric - much love for the word 'bogosity'!

    I have updated the plug in to 1.2.1.

    Also, I noticed the short code in my post was in a different font to the rest of the post - so I retyped it in above, and deleted the different type version. Which seems to have fixed it, and it's only displaying the relevent tags now.

    Dunno what I changed or if it's just the latest version kicking in!

  7. Chris_Page
    Member
    Posted 1 year ago #

    Hi

    Just wanted to say I'm still actually getting trouble with these short codes. The shortcode only seems to work if only one tag is used - as soon as a second is added (with a comma, no spaces) it stops displaying.

    I've tried making sure the tags are actually assigned to a post - when I use each tag individually it works, it just stops displaying as soon as I try to add more than one tag.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags