WordPress.org

Ready to get started?Download WordPress

Forums

Where is the user registration email pulled from? (17 posts)

  1. Will Taft
    Member
    Posted 7 years ago #

    I have the issue with new users not receiving their password emails. I asked for a working link to a possible solution in another thread, but that has not been posted yet. In trying to fix that issue, I found another (related?) problem.

    When a user registers on my site, I get the notification email. 2 days later I also get one of those "MAILER-DAEMON" emails notifying me of a failure. This was also happening when someone used the Contact Form on my site. I seemed to track it down to having an auto responder on the email that the contact form and new user registration was going to. I put in a new email account without an auto responder for the contact form to use and that seems to have stopped those failure notices. I still get them when a new user registers, however.

    I changed the email address on my Dashboard>Options>General field ("used only for admin purposes"),to the new email without the auto responder but I got another failure notice this morning.

    Does the new user registration use that Options>>admin email or does it pull it from somewhere else?

    Thanks!

  2. JustinRDev
    Member
    Posted 7 years ago #

    Before really suggesting anything, I'd like to see a copy of a mailer daemon posted, if possible.

  3. Will Taft
    Member
    Posted 7 years ago #

    Here is a copy of one that was generated from a new user registration a few days ago. It is not the one I received this am as I already deleted that one. (I had about 25 of these in my inbox! I mucked up all the real email address below as I am paranoid about posting real emails in forum threads.

    One common and strange thing about all the daemons is that they refer to an email address that starts with "shepard". This is not a valid address and is not on my site or on the email accounts at my host. We have not been able to figure out where the daemon gets that address, but it is not from WordPress.

    As I said above, I thought it was caused by the auto responder that I use on my email accounts so I set up an email account that does not auto respond. This seems to have reduced the number of daemons received.

    -----------------------------------

    We're sorry. There's a problem with the e-mail address(es) you're trying
    to send to. Please verify the address(es) and try again. If you continue
    to have problems, please contact Customer Support.

    <shepard......secureserver.net>:
    Sorry, I wasn't able to establish an SMTP connection. (#4.4.1)
    I'm not going to try again; this message has been in the queue too long.

    --- Below this line is a copy of the message.

    Return-Path: <W...@.com>
    Received: (qmail 15922 invoked by uid 1000); 26 May 2007 19:34:43 -0000
    Message-ID: <20070526193443.15920.qmail@smtp11-01.prod.mesa1.secureserver.net>
    Date: 26 May 2007 12:34:43 -0700
    Delivered-To: Will@.com
    Precedence: junk
    To: shepard......05.shr.phx3.secureserver.net
    From: "Will" <Will@..com>
    Subject: [Auto-Reply] [WT . com] New User Registration

    Thank you for contacting me. I will respond to your email as quickly as possible.

    -Will

  4. Harveyg
    Member
    Posted 7 years ago #

    Hi, after upgrading from 2.0.3 to 2.2 (and I followed the upgrade steps verbatim, which took me 5 hours for a huge blog, I no longer receive password change request emails nor do new users who register receive their emails. I have also used the Lost Password option for my own accounts on this blog and no longer receive those emails either.

    I have scanned your forums and only find this and one other request re this error... I am now having to manually change new users passwords and manually email them to get them online and commenting for the moment...needless to say with 20+ registrations per day, this is taking a lot of my time!

    Yours in hope...

  5. Will Taft
    Member
    Posted 7 years ago #

    This thread is really about another issue. You might have better luck starting your own thread, but there are lots of threads that address the issue of users not receiving their passwords.

    http://wordpress.org/search/%22registration+email%22?forums=1

  6. Harveyg
    Member
    Posted 7 years ago #

    Thanks WT, I will look at those that I missed, regards H

    Does this one have any bearing on our problems?

  7. JustinRDev
    Member
    Posted 7 years ago #

    Well, you're not having a permissions denied error. Email is working, but it's getting stuck. It looks like (and its been several years since I've had to trace headers so I could be wrong) your host has some messages stuck in the outgoing Q for a malformed email address.

    From what I can tell, "shepard" has nothing to do with WordPress and the fact that the address actually looks like a full server name or such. I honestly think the email is getting bounced around inside the local hosting farm that secureserver.net has setup.

  8. Will Taft
    Member
    Posted 7 years ago #

    Thanks Justin! Unfortunately, secure server is godaddy and they are not yet able to figure out why it is bouncing around or why and where secure server is coming up with the "shepard" email address. Oh well.

    I actually have another issue I have been working on today and can't solve. I notice your blog does exactly what I want mine to do, so maybe you can help?

    My site displays fine in Firefox. In IE it is also fine until a user opens up that left side panel that contains favorites and history which reduces the width of the screen. What I want is for my pages to automatically scroll with the horizontal scroll bar popping up on the bottom if the horizontal screen space gets too small to display the entire content. This is exactly what your blog does. On mine as the user widens the left side favorites panel, first the two sidebars are reduced in width and finally one bumps to the bottom of the page. I have tried making the sidebars and / or the main content area fixed widths instead of %'s. I can gain some control with these changes, but in no circumstance will the scroll bar come up.

  9. JustinRDev
    Member
    Posted 7 years ago #

    Hm - odd that they can't have an engineer peer into the Q and see whats happening.

    It's off topic for this thread, but check out the CSS file that runs my theme:
    http://www.webtekconcepts.com/wp-content/themes/freshy-10/style.css

    Basically, everything is hard coded on the pixel level.

  10. Will Taft
    Member
    Posted 7 years ago #

    Yes, it is odd, I thought it would be easy for them also. But they have not been able to figure it out. All I have been able to figure out on my own is that the secureserver does not like it if an email does not go through and the return email on my site has an auto responder on it.

    I have been able to reduce the bounces by making all my administrative emails go to an address without an auto responder. The last one that causes a problem is that whenever a new user registers on my site, the initial password email is not sent to them. (Common problem in WP blogs, it seems, but that is a whole other issue.) I am hoping that by changing the email address in "options" to one without an auto responder, I might stop the last of these daemon messages.

    I am hoping that someone eventually comes up with the solution to the "password is not sent" bug.

  11. moshu
    Member
    Posted 7 years ago #

    I don't have hosted anything on godaddy.
    However, on some other hosts I have seen the email not working (neither in contact form, nor in regitration) IF the email was not of the same domain as the blog.

    Maybe it's worth to give it a try.

  12. Will Taft
    Member
    Posted 7 years ago #

    Thanks! Do you mean my emails for my site, like my WP>options>admin email?

    If so, I think I am of the same domain, since my email address is like this: name@mydomain and my WP blog is in a directory like this: mydomain/wordpress

    Or, did I misunderstand your suggestion?

  13. moshu
    Member
    Posted 7 years ago #

    Yes, that's what I meant but it seems it wasn't very helpful.

  14. Will Taft
    Member
    Posted 7 years ago #

    OK, thanks and don't worry about whether it was helpful or not. I have seen your answers around this forum enough to know that most of the time when you chime in it is with a solution, so your input is appreciated.

    I am getting optimistic that the daemon bounces will be greatly reduced by my making sure my admin email does not have an auto-responder on it.

    The issue of registration and password emails not being sent is another question, though. A couple of us have asked at the end of this thread about an updated link to a possible solution, but no response yet. Can you take a look at that thread in case you can add anything there? Thanks!

  15. whooami
    Member
    Posted 7 years ago #

    i have the file, check the other thread.

  16. jdspeer
    Member
    Posted 7 years ago #

    I have a similar issue that the new user login notification is never sent due to a malformed email address. the smtp server has two issues.

    1. the name part of the sending email address has quote marks around it (example: "wordpress"@blogname.com)

    2. there has to be a user account for the sender. in the example above there would have to be an account for wordpress.

    My issue goes even further since it is a sub domain. I have been able to hard code in pluggable.php so that it no longer sends "wordpress"@blogname.domainname.com to the admin it will send it as webmaster@domainname.com but to the new user it tries to send as "webmaster@domainname.com"@domainname.com
    Obviously this is an extremely malformed address.

    I am not that great with PHP but it's clear that to solve this problem somehow I need to be able to strip the quotes from the new user notification and be able to hard code the sending email address.

    Any ideas?

  17. Toodledee
    Member
    Posted 7 years ago #

    I have been able to hard code in pluggable.php so that it no longer sends "wordpress"@blogname.domainname.com to the admin it will send it as webmaster@domainname.com

    Can you please share your code changes?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.