WordPress.org

Ready to get started?Download WordPress

Forums

Where is ABSPATH (and INC) Folder? (8 posts)

  1. mhblatt
    Member
    Posted 6 years ago #

    I am having errors with WordPress, permission denial errors, and I was told to chmod the ABSPATH and INC folders. I'm having a whole lot of trouble finding them. Where are they?

  2. mhblatt
    Member
    Posted 6 years ago #

    Okay, so I guess I have to define ABSPATH, how do you do that?

  3. homeycomb
    Member
    Posted 6 years ago #

    in the other thread you mention this:

    Both WP-Settings and Compat are at 777, and they are both in the file WP-Includes.

    why do you have a directory chmodded to 777 unnecessarily?

    Good hosts actually prevent files from from being executed within insecure directories.

    If you are confident that the files are where they belong, then start by applying the proper permissions to the wp-includes/ directory. See where that gets you.

  4. mhblatt
    Member
    Posted 6 years ago #

    What should I have the files as?

  5. moshu
    Member
    Posted 6 years ago #

    Permissions: folders 755, files 644.

  6. mhblatt
    Member
    Posted 6 years ago #

    Works, but now my design changes are gone...

  7. moshu
    Member
    Posted 6 years ago #

    Design changes should alsways be done on your own computer in a plain text editor (after having backup copies of all your template files) - and uploading the modified files via FTP to the server.
    So, I don't see anything that should make impossible to re-apply your changes to the online files.

  8. pedro501
    Member
    Posted 6 years ago #

    I'm also having this problems. I'm installing WP 2.5 and my wp-includes and all internal folders have 755 perms and all internal files have 644 perms and I'm still getting the same error trying to install it.

    wp-setup-config.php is having the problem and it's basically saying it doesn't have permission to open the required compat.php.

    PHP Warning: require_once(../wp-includes/compat.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: Permission denied in <HIDDEN HOST STUFF>/wp-admin/setup-config.php on line 7

    Do you still think this is a permissions thing or possibly something wrong with my server configuration? I've spent about four hours now googling possible solutions but have yet to find one that works.

Topic Closed

This topic has been closed to new replies.

About this Topic