WordPress.org

Ready to get started?Download WordPress

Forums

Where do you specify the email server for submitting a contact form? (9 posts)

  1. rmgallery
    Member
    Posted 3 years ago #

    I am new to WP so not aware of how this works.

    I installed a theme on my page and the theme comes with a contact form. the theme has a 'Email Address for Contact Form' field where i have specified my email address for receiving contact emails. when i try to test this i always get 'Your email failed. Try again later.'

    I also created a separate contact form using the contact template separately from the theme above but there also i get the same error 'Your email failed. Try again later.'

    I'm wondering where do we specify the POP mail server settings for the contact form to work? I saw a 'Post via e-mail' option under Settings->Writing where it asks for mail server, mail id and password.

    I'm not sure why we need a id and password here if this is the place where we specify the POP mail server name for email transmissions.

    Thanks

  2. Micah Cooksey

    Posted 3 years ago #

    My guess would be either the theme options page (if there is one) under Appearance > Yourtheme Options or the email address for your user account (you can change this at Users > Your Profile).

    If you can't get the built-in contact form to work, consider using a contact form plugin such as Contact Form 7.

  3. rmgallery
    Member
    Posted 3 years ago #

    i have a options page for my theme and i have entered an email address (not the POP server name) there but still get the same error there as well as on the custom contact form i created.

    Just as an FYI, my site is still running locally on my local web server and its not yet on the internet. Not sure if that matters.

  4. Micah Cooksey

    Posted 3 years ago #

    I'm sorry; you mentioned that in your first post and I missed it.

    What theme are you using? If you've filled out your email address in the theme options page and it's still not working, it could be a problem with the theme itself. Running your site locally might have something to do with it, but I can't say for sure.

    The "post by email" settings are something completely different. Those are for creating blog posts by emailing them to a "secret email address" from which WP posts them to your site.

  5. rmgallery
    Member
    Posted 3 years ago #

    i doubt it has something to do with my theme as the custom contact page I created using the contact template also gives me the same error. i am using the 'boldy' theme http://wordpress.site5.net/boldy/

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    I believe WP uses php mail. So it would be dependent on your host

    Running locally, do you have a mailserver set up?

    When I set up a wamp server, I had to set up to sent my emails through gmail from my localhost

  7. rmgallery
    Member
    Posted 3 years ago #

    my local server is apache. where do i configure the mail server?

  8. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    You have to install one.... depending on what you set up, you may or may not have one....

    I used wampserver, it didn't have one, due to security implications, spam, etc.

    I configured to send using gmail....

    checkout the last post here http://www.phpfreaks.com/forums/index.php?topic=205062.0

    maybe.... otherwise google for something like apache localhost send mail

  9. rmgallery
    Member
    Posted 3 years ago #

    i tried this but does not seem to work. see my settings below from php.ini file. Btw, i tried both port 25 and 995 and both don't work.

    [mail function]
    ; For Win32 only.
    ; http://php.net/smtp
    ;SMTP = localhost
    SMTP = smtp.gmail.com
    ; http://php.net/smtp-port
    smtp_port = 25
    ;smtp_port = 995

    ; For Win32 only.
    ; http://php.net/sendmail-from
    ;sendmail_from = me@example.com
    sendmail_from = myname@gmail.com

Topic Closed

This topic has been closed to new replies.

About this Topic