WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] where do I put my mp3 files so they can be found? (5 posts)

  1. Ktheimer
    Member
    Posted 7 years ago #

    Newbie warning.

    So, I'm trying to put a largish mp3 file on my site. I read in previous posts that you can't use the upload feature to do this--you've got to ftp it directly to the file system. I wasn't sure where to put it. I tried a couple of different locations, and then looked for it where the other things I've uploaded (like pictures) are located. I noticed on another thread (from wolf693)that it looks like other people are having trouble with this too, but can someone confirm where I was supposed to be putting this file, just to make sure I'm not making a newbie mistake?

    And once I get it in the right place, has anyone solved the problem of having it show up?

    Thanks in advance!

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    You should be able to use the upload form. I've done it before and it works for me.

    The upload form puts things into the wp-content/uploads directory.

    And if you don't use the upload form, it won't appear in the list of uploaded files in that upload form space. You'll have to link to it manually.

  3. demonicume
    Member
    Posted 7 years ago #

    you should create a directory where ever you want it. i put things in root just to keep them simple.

    http://yoursite.com/mp3folder

    then upload to that folder.

    then you have several options to play the file. but either way, youre gonna call it

    http://yoursite.com/mp3folder/bigassmp3.mp3

    in fact, i think that if you simply typed the address in a browser, it should play for you.

  4. Ktheimer
    Member
    Posted 7 years ago #

    Otto42--well, I tried using the upload form and maybe I'm just not patient enough, but it didn't seem to be working. The file is about 22 MB and I thought I had read somewhere that that was too big for the upload tool to use. Maybe I should just give it longer . . .

    Demonicume--I just tried that and it didn't work either. But, I'm using GoDaddy hosting, so things might not be straightforward. I'm going to call them and see if they can give any help.

    Thanks!

  5. Ktheimer
    Member
    Posted 7 years ago #

    Ok--well, I got it working--not quite sure what I did wrong, but I think your comments helped. Thanks a lot.

Topic Closed

This topic has been closed to new replies.

About this Topic