WordPress.org

Ready to get started?Download WordPress

Forums

Propel
[resolved] Where are "settings"? (15 posts)

  1. Accidental Webmaster
    Member
    Posted 3 years ago #

    Hi, I installed Propel, and the documentation indicates I can change the "interface design" via the settings page. I see no settings page or anywhere else I can set this. Under the propel group there is only "propel","dashboard" and "projects", and there are no settings on any of there. What am I missing?

  2. John
    Member
    Plugin Author

    Posted 3 years ago #

    jremley, the latest release included a major overhall of the codebase, and I forgot to include the settings. I will push out a patch to fix this today or tomorrow.

  3. Accidental Webmaster
    Member
    Posted 3 years ago #

    Hello. I updated to your new release, and now see a settings page. The problem, however, is that this page does not affect the output at all. No matter what option I choose, the front end display remains black with white font, which contrasts sharply with my theme. Any way to actually make these settings work? Also, once they work, a "preview" image on the settings page would make it much easier.

    Thank you.

  4. John
    Member
    Plugin Author

    Posted 3 years ago #

    Is there anything special about your WordPress install? Are you using WordPress multi-site? Custom directory structure?

    When you choose a different option, does the value reamin changed in the backend? (ie: if you select flick and press submit, is flick still selected?)

    If so, can you look at your front end source and verify that something like this is being included: /wp-content/plugins/propel/themes/flick/jquery-ui-1.8.6.custom.css?ver=3.1.3

    If so, can you make sure that that css file exists?

    (if you don't know how to do the latter two, post your URL and I can check).

  5. Accidental Webmaster
    Member
    Posted 3 years ago #

    Thanks for the quick response. Here is what I found:

    Is there anything special about your WordPress install? Are you using WordPress multi-site? Custom directory structure? >no

    When you choose a different option, does the value reamin changed in the backend? (ie: if you select flick and press submit, is flick still selected?) >yes

    If so, can you look at your front end source and verify that something like this is being included: /wp-content/plugins/propel/themes/flick/jquery-ui-1.8.6.custom.css?ver=3.1.3 >yes,it is in the source

    If so, can you make sure that that css file exists?>yes

    Any other ideas?

  6. John
    Member
    Plugin Author

    Posted 3 years ago #

    Well, the majority of the front end interface uses jquery-ui. It be possible that there is another plugin including the jquery.ui styles and overriding Propel's styles or conflicting with jquery tabs. If you know how to open the JavaScript console, are there any errors?

    The only other thing I can suggest without actually seeing the site in action, is to try defining your own styles in your themes style.css. Everything is wrapped in a class called "propel-status." So you could try defining the styles of its descendants.

    If you want me to take a closer look at it, I'd need to know your URL. If you don't want to post it here, you can send it to me via my contact form here: http://goo.gl/dBWKc

  7. Accidental Webmaster
    Member
    Posted 3 years ago #

    Hi - thanks again. Trying to use your contact form, but your site seems to be down?

  8. John
    Member
    Plugin Author

    Posted 3 years ago #

    Er. yes, try now.

  9. John
    Member
    Plugin Author

    Posted 3 years ago #

    Ah, there is another jquery-ui.css being included after Propel's which is causing the style conflict.

    <link rel="stylesheet" id="jquery-ui-style-css" href="<url-removed>/plugins/quick-post-widget/css/jquery-ui.css?ver=3.1.3" type="text/css" media="all">

    I'll see what I can do about this - in the mean time, I've also tagged the other plugin author.

  10. Accidental Webmaster
    Member
    Posted 3 years ago #

    Yep, when I disabled the other, I see it work. I do need both to make this collaboration site work. Any help you can provide to make them play nice together would be greatly appreciated! Thanks again.

  11. John
    Member
    Plugin Author

    Posted 3 years ago #

    So, jQuery now supports a custom CSS scope (which will rectify this problem). Since future versions of Propel will offer loading the jQuery UI styles from Googles CDN (which do not use custom CSS scopes), I've decided to not add a scope the themes that are bundled with Propel as it will lead to confusion. However, in version 1.7.1, I have built in support for users to use a custom CSS scope if they role their own theme.

    I have done my best to described this process here: http://goo.gl/Ym74F

    If you have any question or problems with creating your own theme, please let me know.

  12. Accidental Webmaster
    Member
    Posted 3 years ago #

    Thanks for your efforts. I found a little simpler way to get around the problem for now- I just added a condition in the other plug in so it doesn't load the jquery css on the page I have propel. Thanks again!

  13. inapan
    Member
    Posted 3 years ago #

    @jremley,

    I'm the author of the Qick Post Widget. Sorry for the delay in my reaction but I've been busy.
    I will try to put scoping in a future version (not in the next one because it's allmost finished).

    Could you share you're solution in code to the rest of us?
    Perhaps others can benefit from it.

    Thanks in advance!

    inapan

  14. Accidental Webmaster
    Member
    Posted 3 years ago #

    Hi inapan, I simply modified quick-post-widget.php around line 40: I removed the call to load jquery-ui.css from the if (!is_admin()) conditional, and put it in a separate condition prior which only loads it on the page where I am using the plugin:


    if (is_page(118)) {
    wp_enqueue_style('jquery-ui-style', $qpw_plugin_url . 'css/jquery-ui.css');
    }
    if (!is_admin()) {
    wp_enqueue_script('tinymce', get_bloginfo('wpurl') . '/wp-includes/js/tinymce/tiny_mce.js');
    ...
    }

    I've used this method on another site to speed up the page load. It would be great if wordpress had a native ability to prevent scripts from unnecessarily loading on every page. Note this is probably not the best method as I'll have to re-do this if I upgrade the version of your plugin and this file gets overwritten. Hope this helps.

  15. inapan
    Member
    Posted 3 years ago #

    @jremley,

    Thanks!

    inapan

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic