WordPress.org

Ready to get started?Download WordPress

Forums

Post By Email
When you include an image, short code doesn't trigger and copy not displayed (8 posts)

  1. Developer ICAN
    Member
    Posted 4 months ago #

    Hi,

    When you include an image, a few things stop working ..

    1) Shortcode for adding a post into a certain category doesn't work ie [category 8]

    2) Text doesn't appear in the post

    Can you help with this?

    Thanks for your time

    https://wordpress.org/plugins/post-by-email/

  2. Developer ICAN
    Member
    Posted 4 months ago #

    Hi,

    Is there anyway i can get a response on this?

    Thanks

  3. Developer ICAN
    Member
    Posted 4 months ago #

    I guess not

  4. Kat Hagan
    Member
    Plugin Author

    Posted 4 months ago #

    Can you provide me with more information? It works for me in my testing. What email client are you using? What version of WP and PHP?

  5. Kat Hagan
    Member
    Plugin Author

    Posted 4 months ago #

    (Also, this plugin is not my full-time job, nor even my job at all. I am the only person working on it and maintain it entirely in my free time. So please have patience when making support requests. Cheers.)

  6. Developer ICAN
    Member
    Posted 4 months ago #

    Hi Kat,

    I appreciate that and great work honestly. I apologise for the haste - it's just a nice plugin and i'm sort of depending on it for a job.

    There are a few items not working and rather than do this myself, i just wanted to see would you be able to rectify these before i start hacking.

    1) I done a test from Gmail - just typed a few words and ran it and it put in an unmerciful amount of junk HTML

    2) When you include an image AND text - the text doesn't appear - image takes over all precedent - it even takes precenent over the short codes

    Thanks Kat and honestly nice work.

  7. Kat Hagan
    Member
    Plugin Author

    Posted 4 months ago #

    I would LOVE pull requests if you've got time. It's a huge help when others with tech knowledge can fix things, especially since the nature of this plugin makes it very hard to test on all possible configurations. So let me know if you decide you would like to do some hacking and I'd be happy to help with any questions. The GitHub repo is here: https://github.com/codebykat/wp-post-by-email

    That being said, I've done some work trying to track down the image embed thing, and I think it's a bug with the underlying library (Horde), and the fix is to switch to using PHP's included IMAP functions, when they're available. So it's a fairly major bug. The HTML formatting might be something more straightforward.

    Thanks for the kind words, and I apologize if I sort of snapped at you. I do try to at least reply to the requests here, but it can be hard to stay on top of and that gets frustrating. :)

  8. Developer ICAN
    Member
    Posted 4 months ago #

    Thanks Kat, appreciate your response. I'll see what i can do on this OK and if i can get to it, i'll get back to you.

Reply

You must log in to post.

About this Plugin

About this Topic