WordPress.org

Ready to get started?Download WordPress

Forums

qTranslate
When will the qTranslate update for WP 3.8 be available? (44 posts)

  1. bradleyrose001
    Member
    Posted 4 months ago #

    Got this message on my dashboard after updating to WP 3.8:

    "The qTranslate Editor has disabled itself because it hasn't been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version."

    When will the qTranslate update for WP 3.8 be available? Is Version 2.5.38 tested on WP 3.8 yet?

    http://wordpress.org/plugins/qtranslate/

  2. 3Lancer
    Member
    Posted 4 months ago #

    Hi,

    No idea when the developer will update or release a new version, but believe it won't be affected anyways.

    The 'Parker' update, aka WordPress 3.8, just features a responsive, redesigned dashboard and a few minor fixes. It should be all unrelated (except for possible widgets).

    However so far tested this only a DEV Server and seems to be working fine without any major modifications. I have so far seen no issues and will release to live next week. Detected no compatibility issues.

    If you so desired, recommend backing up database and files first.

    Edit: qtranslate.php

    Update this line to the WordPress version -
    define('QT_SUPPORTED_WP_VERSION', '3.8');

    This will make it work without that warning message popping up. Just save and refresh.

  3. lluisrd
    Member
    Posted 4 months ago #

    Wow
    Doesn't work properly with wordpress 3.8, at least in the site I have tested.
    No works qtranslate25.38 and Qtranslate_development_version.
    Repeat pages two by two and finally you have 8 or 10 pages.

    Well, I'm waiting new version for this really good plugin

    About WordPress3.8: looks nice but awfull and horrid font

  4. djender
    Member
    Posted 4 months ago #

    same here, plugin completly lost control over post editing. For some reason when plugin is enabled, post do not contain any formating, just stream of words, one after another.

  5. tobifjellner
    Member
    Posted 4 months ago #

    Version 3.8 contains big changes on the administration pages. For instance, I have noted that non-latin text in the admin-panel does not render correctly with qtranslate.

    So I guess that the quick hack of just telling qtranslate to be happy with the latest version of WordPress may not fully cut the issue here.

    The author of qtranslate is more likely to see your comments and follow up if you post in the support forum for qtranslate:

    http://www.qianqin.de/qtranslate/forum/

    But, at the same time, that forum is totally bombarded by bots. A meaningful post would simply drown in awful digital mud...

  6. connyQ
    Member
    Posted 4 months ago #

    the same problem here after uptate on 3.8 - on backend both languages are on one site - no control :( Did someone have an idea?

  7. felix007
    Member
    Posted 4 months ago #

    You can update the plugin version to work with 3.8
    need to open wp-content/plugins/qtranslate/qtranslate.php
    and change line 90
    from define('QT_SUPPORTED_WP_VERSION', '3.7.1');
    to
    define('QT_SUPPORTED_WP_VERSION', '3.8');
    save and you done!!!

  8. lluisrd
    Member
    Posted 4 months ago #

    felix007.
    I've changed line 90 and I had a test for one page.... and works.
    (qtranslate 2.5.38 and WP 3.8)

    tnxs Felix

  9. rodrigodonini
    Member
    Posted 4 months ago #

    Works fine for me!
    thx!

  10. jhernandis
    Member
    Posted 4 months ago #

    @felix007 a lot of thanks, works fine! :)

  11. lluisrd
    Member
    Posted 4 months ago #

    I've all pages.
    Works good

  12. germainphil
    Member
    Posted 4 months ago #

    It works for me too ! weldone for advice ;)

  13. Simon
    Member
    Posted 4 months ago #

    While I can get the editor working again in 3.8 by modifying QT_SUPPORTED_WP_VERSION, I have troubles with the "read more" functionality:

    When qTranslate is active, they do never appear, when I disable the plugin they are fine again (showing in the default language of course).

    Removing and re-adding the read-more link in the article works fine again.
    Does anyone else notice this?

  14. tobifjellner
    Member
    Posted 4 months ago #

    Now I think I know what was broken for me in WP 3.8:

    The new, nice admin-interface uses special fonts, which are, fetched from Google when needed. But...
    If your main language is, say, English, and then you add a second language which uses a different character subset than English, then this additional subset won't be requested. So for me, all Russian text in the admin interface doesn't have any graphical representation, and is therefore invisible!

    In a purely Russian installation, I don't get this issue, since then the WP core makes sure that the correct additional character subset is loaded. Here's what it looks like on one of my sites.

    <link rel='stylesheet' id='open-sans-css' href='//fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext&ver=3.8' type='text/css' media='all' />

    Perhaps with Qtranslate one needs to somewhere tick a list of what character subsets may be needed for your particular site.
    I'll dig a little bit deeper. But, until further notice, I hold back on moving to WP 3.8 for my multilingual sites...

  15. Nins
    Member
    Posted 4 months ago #

    Hi,

    I did as felix007 says but now i have the error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/nins/public_html/wp-content/plugins/qtranslate/qtranslate.php:1) in /home/nins/public_html/wp-content/plugins/qtranslate/qtranslate_core.php on line 71

    Any idea how fix it?

    Thank you for your help

  16. tobifjellner
    Member
    Posted 4 months ago #

    Nins wrote:

    I did as felix007 says but now i have the error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/nins/public_html/wp-content/plugins/qtranslate/qtranslate.php:1) in /home/nins/public_html/wp-content/plugins/qtranslate/qtranslate_core.php on line 71

    Any idea how fix it?

    Dear Nins, I get the same issue if I use the built-in plugin editor in WordPress.
    But, if I edit the file on my local computer (Notepad++ on Windows), and then upload it via ftp, then everything is OK.
    I guess the online editor breaks something in the file...

    Update: Ehm. No, I get a different error.
    Here it looks as if there is something in line 1 that is sent as output. Make sure that there is no space or empty first line in the file. Best is to take a fresh install of qtranslate, and then locally edit the supported version, without changing anything else, and then upload it.

  17. Nins
    Member
    Posted 3 months ago #

    Thanks tobifjellner !

    I did as you say with Notepad++ and now works fine.

    Thanks !

  18. Shakib R Khan
    Member
    Posted 3 months ago #

    change line 90 from: define('QT_SUPPORTED_WP_VERSION', '3.7.1');
    to: define('QT_SUPPORTED_WP_VERSION', '3.8');

    save and you done!!!

    It's working Really Fine!!!

    Thanks a lot Buddy :)

  19. Psychosopher
    Member
    Posted 3 months ago #

    Thank you! This works for me!

  20. nightshifter1809
    Member
    Posted 3 months ago #

    Thanks a lot felix007. Your sollution saved my wife's website :)

  21. reuberconsult
    Member
    Posted 3 months ago #

    Thank you! It Works also for me!

  22. gennadik
    Member
    Posted 3 months ago #

    Works fine for me in WP 3.8 with Reactor theme for German, Russian and English. It does all I need:
    - translated pages
    - translated menu items
    - shortcode for Language Selector widget:
    <?php echo qtrans_generateLanguageSelectCode('dropdown'); ?>

    Thank you

  23. danibo
    Member
    Posted 3 months ago #

    Hallo
    I have to upgrade WP from 3.61 to 3.8 because Mojo (simple scripts does not allow to upgrade to version 3.7.1 first). I have installed q-Translate 2.5.37.

    Do you think it works with the follwing advice as well?

    You can update the plugin version to work with 3.8
    need to open wp-content/plugins/qtranslate/qtranslate.php
    and change line 90
    from define('QT_SUPPORTED_WP_VERSION', '3.7.1');
    to
    define('QT_SUPPORTED_WP_VERSION', '3.8');
    save and you done!!!

    Or is the step to big.

    Thanks danibo

  24. gennadik
    Member
    Posted 3 months ago #

    > Do you think it works with the follwing advice as well?
    - it works with q-Translate 2.5.38 and WP 3.8. as for 2.5.37 why you just not try?

  25. cei1807
    Member
    Posted 3 months ago #

    Hi everyone!
    I installed Qtranslate yesterday, and everything worked fine at the beginning, I was able to translate all menus with no problem but I'm unable to write text in pages with language tags and I cannot see the content in the current language, instead I see all the languages. I attach the screenshot so it will be best for you to understand.
    I use theme Pagelines DMS, WordPress 3.8 and qtranslate 2.5.38. And I also changed line 90 in qtranslate code to make it compatible with 3.8 but nothing changed (only alert messages)
    I am not an expert at coding, do I need to add some php code somewhere apart from the post?

    Any help would be much appreciated!

    You can see a screenshot here: http://forum.pagelines.com/uploads/monthly_01_2014/post-63064-0-28052400-1389299955.jpg

  26. gennadik
    Member
    Posted 3 months ago #

    @cei1807
    Hi,
    It's better to start the new thread/topic with such a request as it's not about qTranslate update for WP 3.8

    Try to use any other theme besides Pagelines DMS and see if you have same problems. twentyfourteen should be there as you have WordPress 3.8. I believe this problem is specific to theme/plugins compatibility, so it is not that easy to fix.

  27. cei1807
    Member
    Posted 3 months ago #

    @gennadik
    Oh sorry for any inconvenience! I post it here because I thought it may be because of the update of qTranslate. I'll start a new topic then. Thanks anyway

  28. gennadik
    Member
    Posted 3 months ago #

    it's not about inconvenience but about to get more attention/traffic to your problem :)

  29. Rhand
    Member
    Posted 3 months ago #

    I was about to add some more content to a site that is almost done, but now that I upgraded to WordPress 3.8 I see this warning too:

    The qTranslate Editor has disabled itself because it hasn't been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version.

    I saw at qTranslate that a version that guarantees working well with 3.8 is not done yet and changing a plugin core file to say that it does is not a great solution either.
    Unlike @tobifjellner issue with non latin characters my site only uses German, English and Dutch so I guess I will not have an issue with that. I did make a backup so I will give it all a shot shortly and see. I will turn on debug as well just in case.

  30. whaus
    Member
    Posted 3 months ago #

    changing a plugin core file to say that it does is not a great solution either.

    there's no problem with changing the supported version number, if the mechanics the plugin uses still work with the new WP version.

    it works for me. and btw, also with WP 3.9-alpha

Reply »

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.