WordPress.org

Ready to get started?Download WordPress

Forums

When Permalinks set to post name, no links work (4 posts)

  1. katesbeauty
    Member
    Posted 2 years ago #

    When I try to change my Permalinks to anything other than default (i.e. a random number assigned to each post), none of my links work - i.e. if you click "Continue Reading" or "About", it just keeps redirecting to Home Page. Can you please help?

  2. threestyler
    Member
    Posted 2 years ago #

    Can you give an example of the custom permalink settings you are trying to use?

    Also check the codex re pretty permalinks:

    http://codex.wordpress.org/Using_Permalinks

    Finally confirm a .htaccess file is being created in the root of your installation as this is required for custom permalinks.

  3. katesbeauty
    Member
    Posted 2 years ago #

    Basically I just want to be able to select the option that has the post name appearing in the URL: Post name http://katesbeautyblog.com/sample-post/

    But when I try to select that, none of my links work. Instead I am just redirected to my home page. The only option that works is: Default http://katesbeautyblog.com/?p=123

    I will check out that link you provided - thank you!

    With respect to your last point, I really have no idea - I am new to the blogging word! How do I set up a .htaccess file/see if it is being created?

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    FTP into your site (or use whatever file management application your host provides) & look for an .htaccess file in your root WordPress folder. Bear in mind that some ftp clients are configured to hide .htaccess files, so do ensure that your client is configured to show all files.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.