WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] when i posting, I have small problem (4 posts)

  1. musicfeeler
    Member
    Posted 3 years ago #

    I know this is going to very basic question. But I tried entire day for this problem and Finally I'm fail.. I Really need you guy's help
    Above all, I use tanzaku's theme ( http://www.tripleships.com), I don't think this is theme's problem

    Anyway, Please check out my blog

    http://musicfeeler.comeze.com/wordpress/

    when i posting it, I have a problem.

    As you see panda picture , I don't wanna showing full size picture at the first page (Grid?) , which means when i write or post something, I just wanna show thumbnail or relatively small size picture.
    when someone click the excerpt or picture, then i wanna show full size picture. Of course wanna do same thing to Video file

    I'm sorry but I spend almost 5hr for this and I'm totally knock-out

    I expect you guys good advise, thanks

  2. Ben Sutcliffe
    Member
    Posted 3 years ago #

    This is one solution, there are others.

    Install this lightbox plugin. Again, there are others, but this one is pretty easy to use.

    Now open up your post in the admin section (so Posts > Edit). Click or hover over the photo till two buttons appear (Edit and Delete). Click Delete.

    Now, put the photo in again - either select it from your Gallery or upload it. When you insert the image into your post you should select the following options:

    • Link URL: click "File URL"
    • Size: click "Medium"

    Then click Save Changes.

    Now click the HTML tab on the top right of the edit box. Find the link to the picture, which will have code similar to

    <a href="http://longurlhere.com"><img class="someclass" src="http://anotherlongurlhere.com" /></a>

    Directly after the <a at the beginning add rel="lighbox" so that you now have code similar to:

    <a rel="lightbox" href="http://longurlhere.com"><img class="someclass" src="http://anotherlongurlhere.com" /></a>

    Save your post. View your site, open up the post and click the picture.

    Rinse and repeat when using on any other posts.

  3. Yellowfields
    Member
    Posted 3 years ago #

    I think the solution is much simpler than this. Simply edit the index.php file. Near the top there is this code:

    $max_col = 1; // max column size (style div.x1 ~ xN)

    By deafult it is set to 2. Change it to 1, as above. This will ensure the grid view (images) are restricted to one column and not spread over 2, or 3.

    Your website never showed a panda image, but I think this is perhaps the answer you are looking for.

  4. stephentrott
    Member
    Posted 3 years ago #

    Thank you Yellowfields, this helped me too.

Topic Closed

This topic has been closed to new replies.

About this Topic