WordPress.org

Ready to get started?Download WordPress

Forums

When I post a link to my site its titled "Home" (4 posts)

  1. TheSolomonPress
    Member
    Posted 1 year ago #

    Hey guys

    when I post a link to my site, like on Facebook, it shows "Home" as the title/link, and then shows my actual url underneath it real small which is-

    thesolomonpress.com

    I'd love to make that "home" go away so it says "The Solomon Press"

    but I don't want to rename the home page that, because then it will disrupt the bar across the top of my site.

    Any ideas?

    thanks so much

    ~Samuel

  2. Colm Purchase.ie
    Member
    Posted 1 year ago #

    Install Plugin like SEO Ultimate and fill in the Meta Titles and Meta Description every time you create a new page or post and this issue will go away.

  3. workky
    Member
    Posted 1 year ago #

    change the title tag to "The Solomon Press"
    You can do this many ways, Colm Purchase mentioned one of them.

    Depending on your theme options, you can go under The dashboard, go to settings, click on general settings, then change it where it says site title to "The Solomon Press"

  4. TheSolomonPress
    Member
    Posted 1 year ago #

    Changing the title tag is no good because then it causes that title to show up on all my pages, which conflicts with the header I have up.

    It's great to get some SEO thing for new pages, but I'm trying to make this happen for my home page that already exists.

    any other ideas, guys?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags