WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] when i activate permalink, I'm forbidden to access anything! (14 posts)

  1. micasuh
    Member
    Posted 8 years ago #

    I don't understand why this is happening. I'm on a linux server and it supports mod_rewrite, so I'm confused as to why this keeps happening! I'm using WordPress 2.0.1 and would really appreciate some suggestions. I've searched all over for an answer but nothing productive turns up. Thanks!

  2. micasuh
    Member
    Posted 8 years ago #

    bump for any answers!

  3. mictieson
    Member
    Posted 8 years ago #

    I did that, had to start over, grrrrr i feel you pain "daniel son!"

  4. drivetraffic
    Member
    Posted 8 years ago #

    When you configure your permalinks within WP, at the top of the page does it say successful or does it say you must now update your .htaccess file?

    I had a similar problem and all I had to do was put an .htaccess file in the root directory of my blog - the one that sits in the root directory of the site is not the one that was being modified.

    You also want to make sure this file is writable.

    Hope this helps.

  5. micasuh
    Member
    Posted 8 years ago #

    At first, I was getting the message saying that I didn't have a file on the server or it wasn't writable. So I then uploaded one and made it writable.

    Now when I make the change so that permalinks are available, the next thing that happens after I submit the change is that I get the Forbidden 403 error. Huh? 403? Why?!

    So before I even had an .htaccess file in the directory, it always said successful. But once I either copied the info into the .htaccess and saved it, or when I made the .htaccess writable and WP changed the information itself, I could and still can not access the blog or control panel area without deleting the .htaccess file itself.

  6. Clifford
    Member
    Posted 8 years ago #

    Yeap I'm in exactly the same position.

    WP 2.0 or 1.5.2 does not generate a .htaccess file. And when I add one it crashes with a 403 error.

    I've followed everything in the codex - How do you get WP to generate the file? Or how can i add one without it crashing?

    Can anyone shed light on this please?

  7. micasuh
    Member
    Posted 8 years ago #

    I actually just made a blank .htaccess file and uploaded it to the root of the blog folder where the index.php exists. I then made the permissions such that it's writable (666). Then when I successfully add the right text into the .htaccess (or rather, let WP do this for me with the correct permission settings), I get the 403 error.

    What's strange is that I've cross-checked all the settings with another website I'm designing and have no problems whatsoever! It doesn't make any sense!

  8. Clifford
    Member
    Posted 8 years ago #

    I feel your pain.

    I can get it to generate the file now but I have the same problem as you. It crashes with a 403 error.

    This is my server config...

    Operating system Linux
    Kernel version 2.4.21-4.ELsmp
    Machine Type i686
    Apache version 1.3.33 (Unix)
    PERL version 5.8.4
    Path to PERL /usr/bin/perl
    Path to sendmail /usr/sbin/sendmail
    PHP version 4.3.10
    MySQL version 4.0.25-standard
    cPanel Build 10.8.1-RELEASE 30
    Theme cPanel X v2.5.0

    It's doing my head in!

  9. Clifford
    Member
    Posted 8 years ago #

    SOLVED !!! 403's no longer a problem and permalinks working.

    Try adding the following line at the top (the very first line) of .htaccess

    Options +SymLinksIfOwnerMatch

    (Refer to this post micasuh)

    http://wordpress.org/support/topic/6200?replies=10

  10. micasuh
    Member
    Posted 8 years ago #

    I can't explain why, but Clifford, that actually worked! But why? Does anyone else know the answer?

    Also, why the heck can't I find these other posts to begin with? This WP Support area sucks.

    Thanks so much!

  11. Clifford
    Member
    Posted 8 years ago #

    Hey no problem - I've spent hours pulling my hair out too. I think this is an issue with servers running the older apache 1.3 series.

    In the end i searched using Google and it brought up that post eventually.

    And you're right this support forum desperately needs an inbuilt search function.

    Happy blogging!

  12. sleepedge
    Member
    Posted 8 years ago #

    Hey guys, I've had exactly the same problem as you guys (403s when a .htaccess was created). I tried the solution, but its not working for me. I'm a total noob when it comes to wordpress and .htaccess files so I'm not sure if I've edited the .htaccess file properly. Here's what it looks like at the moment (not working):

    Options +SymLinksIfOwnerMatch
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    # END WordPress

    Is that what its meant to look like? Please Help! Cheers

  13. micasuh
    Member
    Posted 7 years ago #

    This is a reply to sleepedge.

    The .htaccess file that you are asking about is exactly how my .htaccess file looks like. Just make sure that the line which says RewriteBase /blog/ is pointing to the correct directory. I'm not sure why you're still having problems after using this code.

  14. shareski
    Member
    Posted 7 years ago #

    My issue is I changed my permalink structure from the default to date and time. Everything has worked except my one of my pages. 3 work and one doesn't
    http://ideasandthoughts.org/videos/
    I forgot I needed to change the header to reflect the link changes but after I did this, the videos page still didn't work.

Topic Closed

This topic has been closed to new replies.

About this Topic