WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] What's wrong with my HTML coding? (9 posts)

  1. RavenJene
    Member
    Posted 1 year ago #

    I really have no idea what went wrong. I am following this tutorial and I am sure I've done everything correctly that was instructed to do up until that point. If needed you can scroll to the bottom for the links that lead to the other parts of the tutorial. I've been fiddling with this since yesterday afternoon. I have NO idea what went wrong. I assumed I didn't close a couple of tags or something and I've even checked W3Schools for validation and I think most of it conflicted with the PHP Scripting. Please help. Much is appreciated. Thanks.

    My website for previewing. My search form or my calender will not show up. Also, the "searchform.txt" document is in the tutorial.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head profile="http://gmpg.org/xfn/11">
    
    	<title><?php bloginfo('name'); ?><?php wp_title(); ?></title>
    
    	<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>"; charset="<?php bloginfo('charset'); ?>" />
    	<meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats please -->
    
    	<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" />
    	<link rel="alternate" type="text/xml" title="RSS .92" href="<?php bloginfo('rss_url'); ?>" />
    	<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="<?php bloginfo('atom_url'); ?>" />
    	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    
    	<?php wp_get_archives('type=monthly&format=link'); ?>
    	<?php //comments_popup_script(); // off by default ?>
    	<?php wp_head(); ?>
    </head>
    <body>
    
    <div id="header">
    		<h1><a href="<?php bloginfo('url');?>"><?php bloginfo('name');?> </a></h1>
    			<?php bloginfo('description');?>
    </div>
    
    <div id="container">
    	<?php if(have_posts()): ?><?php while(have_posts()): the_post(); ?>
    
            <div class="post" id="post-<?php the_ID(); ?>">
    			<h2><a href="<?php the_permalink(); ?>"><?php the_title(); ?></a></h2>
    
                   	<div class="entry">
            			<?php the_content(); ?>
                           	<p class="postmetadata">
    							<?php _e('Filed under:'); ?> <?php the_category(', ') ?> <?php _e('by'); ?> <?php  the_author(); ?><br />
    							<?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?> <?php edit_post_link('Edit', ' | ', ''); ?>
    						</p>
                     </div>   
    
                </div> 
    
    	<?php endwhile; ?>
    
    		<div class="navigation">
    			<?php posts_nav_link(); ?>
    		</div>
    
    	<?php else : ?>
    
    		<div class="post" id="post-<?php the_ID(); ?>">
    			<h2><?php _e('Not Found'); ?></h2>
    		</div>
    
    	<?php endif; ?>
    
    </div>
    
    <div class="sidebar">
    	<ul>
    
        		<li><p>Billy bong bong bangy bang.</p>
                </li>
    
    			<li id="search">
    				<?php include(TEMPLATEPATH . '/searchform.php'); ?>
    			</li>
    
            	<li id="calendar"><h2><?php _e(‘Calendar’); ?></h2>
    				<?php get_calendar(); ?>
    			</li>
    
    		<?php wp_list_pages('depth=1&title_li=<h2>Pages</h2>'); ?> 
    
    			<li><h2><?php _e('Categories'); ?></h2>
    				<ul>
            			<?php wp_list_cats('sort_column=name&optioncount=1&hierchal=0'); ?>
                	</ul>
                </li>
    
             	<li><h2><?php _e('Archives'); ?></h2>
             		<ul>
                		<?php wp_get_archives('type=monthly'); ?>
                	</ul>
                </li>
    
    		<?php get_links_list(); ?>
    	</ul>
    </div>
    
    </body>
    </html>

    As you can see, I've typed some random text in order to get things to show up which is still not working.

    Heeeeeelp. Much appreciated.

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Run your HTML (not the PHP you posted) through W3C's validator and anything wrong will be exposed as errors.

  3. alchymyth
    Forum Moderator
    Posted 1 year ago #

    what template (where you posted the code) is that?

    it seems that this template is not used for your linked site.

    what do you get when you goto
    dashboard - appearance - editor; select your theme; select index.php ?

    also, the style.css has no styles (yet).

    possibly review:
    http://codex.wordpress.org/Theme_Development

  4. RavenJene
    Member
    Posted 1 year ago #

    It's the tutorial template offered by: WP-Designer & it is the theme. & I know it doesn't have as style.css yet but the search bar and calender should still be able to show at least. Im so confused.

  5. alchymyth
    Forum Moderator
    Posted 1 year ago #

    you are possibly (un)happily editing the wrong file.

    what method are you using for editing?

  6. RavenJene
    Member
    Posted 1 year ago #

    I am editing the index.php; I do it through Dreamweaver.

  7. alchymyth
    Forum Moderator
    Posted 1 year ago #

    I am editing the index.php; I do it through Dreamweaver.

    are you using ftp to move the edited index.php file to the server?

  8. RavenJene
    Member
    Posted 1 year ago #

    are you using ftp to move the edited index.php file to the server?

    I can upload to my site through Dreamweaver.

  9. RavenJene
    Member
    Posted 1 year ago #

    I fixed it ! :D I actually still have no clue what went wrong, but it miraculously started working and my search bar & calender are now appearing. You can see that here. *shrug* Lol Thanks for helping though to all who contributed. But I just hope I don't run into anything else like this considering I literally have NO idea what the problem was...after opening & closing tags & even going out of my way to close tags that didn't even exist. [*Oh HTML, how you run my life.] Lol. But thanks again !

    I'm sure it was one measly tag that I didn't close. Who knows?

Topic Closed

This topic has been closed to new replies.

About this Topic