WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] What's different in 3.2 that requires MySQL 5? (4 posts)

  1. Chris Cheney
    Member
    Posted 3 years ago #

    I went into wp-includes/version.php and set the required version of MySQL to 4.0. Everything appears to be running very smoothly. (MySQL 4.1.22)

    Can someone be specific as to what new feature(s) 3.2 has which specifically require MySQL 5?

  2. Knut Sparhell
    Member
    Posted 3 years ago #

    I will leave to others to answer your question specificly, because I don't know and can't find anything that definitely will not work in MySQL 4.1. And I may easily have overlooked something.

    But you should not expect 3.2 to introduce enhancements or new features that require MySQL 5.1. The decision not to support MySQL was "political". WP 3.2 is not yet finished, and a feature that require MySQL 5.1 may be introduced any time, in 3.2, 3.2.1 or later.

    There has been no priority of the current development cycle to make changes just because one can. Faster, lighter, smoother has been the priority.

    But: Support questions and bug reports for a site still running MySQL 4.1 may get very little attention og rejected as invalid.

    MySQL 4 is not supported, to have the freedom of not having to check and test things against that platform.

    The removal of support for MySQL 4 was announced months before WP 3.1 was released.

  3. MySQL 4 was last updated in 2009. Both it and MySQL 5.0 have reached EOL.

    I don't believe WordPress currently does anything that specifically requires MySQL 5.1, however making it the minimum requirement allows for future versions of WordPress to use faster and more optimized queries that were not possible under older versions of MySQL. WordPress 3.2 is just the "let's make the switch and strip a few things" while future versions of WordPress will be "let's rewrite this to be a lot faster now that we don't need to provide legacy support".

    It's pretty much the same reason why PHP4 support was dropped -- old versions suck. :)

  4. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    The primary goal of bumping the requirement was to reduce our areas of test coverage. WordPress will currently work under 4.x, but we're not supporting it, and we won't guarantee it'll work in the future.

Topic Closed

This topic has been closed to new replies.

About this Topic