WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Whatever happened to "Default media links" in wordpress 3.0? (4 posts)

  1. chulk607
    Member
    Posted 3 years ago #

    Hi there. I'm currently trying to find how to set the default link type for media (images) in WordPress 3.0.

    There used to be an option (As shown at the top of the second picture here), which now seems to have vanished from settings.

    I'd like to basically get it so that when a user posts a new thumbnail image to their blog, by default when the thumbnail is clicked, it links to the image directly (link to image), rather than opening the url.

    Any help would be hugely appreciated!

  2. Mark / t31os
    Moderator
    Posted 3 years ago #

    You can still set it using the main options page (not listed in the admin).

    Query your site for the following page.

    example.com/wp-admin/options.php

    Scroll down until you see image_default_link_type and set as appropriate.

    Valid values are still what they originally were, file, post and none if i remember correctly.

  3. seaus
    Member
    Posted 3 years ago #

    does this option exist in 3.x versions of wordpress. I do not see the "file", "post" or the actual setting of the option

    'media' => array( 'thumbnail_size_w', 'thumbnail_size_h', 'thumbnail_crop', 'medium_size_w', 'medium_size_h', 'large_size_w', 'large_size_h', 'image_default_size', 'image_default_align', 'image_default_link_type', 'embed_autourls', 'embed_size_w', 'embed_size_h' ),

    There seems to be nothing specifying the 'image_default_link_type' setting

    Can you advise the necessary code?

  4. flogra
    Member
    Posted 3 years ago #

    i know this thread is 3 month old, and marked as solved but the solutions here as most of the others relate to below 3.0 and since it just took me an afternoon to find the solution, i found it worthwhile posting it here.

    in wordpress 3.0, assuming one works with the files from the twentyten template as an example, open functions.php from the twentyten template folder.

    add the following line to the end of the file, after the last "endif;"

    update_option('image_default_link_type','file');

    you have to re-insert images into posts, but there doesn't seem to be a need to reupload everything like other solutions suggested.

    thanks to adam capriola http://wordpress.org/support/topic/image-link-url-default-none

Topic Closed

This topic has been closed to new replies.

About this Topic