WordPress.org

Ready to get started?Download WordPress

Forums

What may I delete? (14 posts)

  1. mike
    Member
    Posted 10 years ago #

    I just upgraded from .72 to 1.01 "Miles." After I worked out some bugs with 'ABSPATH', the upgrade ran smoothly. Now that all "b2" elements have been renamed, I wondered what I could delete so as to clean up my blog directory. Thanks!

  2. Anonymous
    Unregistered
    Posted 10 years ago #

    *wails for mama guad*
    i have ABSPATH issues and i don't know how to fix them.
    right now my index page says:
    Warning: main(ABSPATHwp-includes/wp-db.php) [function.main]: failed to create stream: No such file or directory in /home/tankgreen/proliferations/wp-settings.php on line 24
    Fatal error: main() [function.main]: Failed opening required 'ABSPATHwp-includes/wp-db.php' (include_path='.:/usr/local/lib/php') in /home/tankgreen/proliferations/wp-settings.php on line 24
    i can't even load the upgrade.php page to upgrade! i just uploaded all the files and now i have this.
    HELP MEEEEEEEEEEEEEEEEEEEEEE!!! :o)

  3. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    Did you redo your wp-config.php? You probably need to.

  4. Anonymous
    Unregistered
    Posted 10 years ago #

    there is no wp-config in this new release. i guess it just works off the old one. shitey bollix!!! another suggestion?

  5. Cena
    Member
    Posted 10 years ago #

    You just have to rename wp-config-sample.php as wp-config.php. Make sure you update your database name, username/password, host in the file.

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    BAAAAAAAAAAAAHAHAAHAA, it is that simple????? ahhahahaaa.
    you all need better instructions for eejits like me.
    thanks! i will try this and see what happens.

  7. Cena
    Member
    Posted 10 years ago #

    Eejits like you should try reading the instructions available, which clearly state:
    "Alternately, you may open wp-config-sample.php in a text editor and insert your database name, username, password, and host name as indicated in the comments. (Comments are lines that start with /* or //.) Save this file as wp-config.php, and upload it."
    --from the readme.html. ;)

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    honestly, it doesn't say that:
    Upgrading from any previous WordPress to v1.0.1:
    Backup your database. Yes, you. Right now.
    Point your browser to /wp-admin/upgrade.php.
    You wanted more, perhaps? That's it!
    and as we can see, that isn't enough...
    its still not working anyway.
    now i get a message telling me that WP isn't even installed. urrgh.

  9. Cena
    Member
    Posted 10 years ago #

    Okay, you obviously skipped the very first part of the installation section of the readme, which is entitled, "New users: 5-minute install." All of the information I've given you in this and the other thread come directly from there. ;)

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    of course i skipped it, i am not a "new user", you know..? i am upgrading so i naturally followed the upgrading instructions. not trying to play semantics, but if we all need to read the "new user" section then i seriously think the instructions need to be rewritten because they are terribly misleading. i know that isn't on you...
    anyway, i still can't get this bugger to work...

  11. mike
    Member
    Posted 10 years ago #

    I will answer my own question:
    Yes Mike, you can delete all b2 files. However, make sure that in index.php you change "b2comments.php" to "wp-comments.php."

  12. Anonymous
    Unregistered
    Posted 10 years ago #

    I have to agree that the installation instructions are poorly labeled. There should be a section that is only for new installations and a section for only upgrading.

  13. NuclearMoose
    Member
    Posted 10 years ago #

    To those discussing the documentation in this thread, please refer to
    this thread to offer specific and detailed suggestions.
    Thanks!
    Craig.

  14. gfmorris
    Member
    Posted 10 years ago #

    Mike:
    To answer your question a bit further, I'd not delete the b2rss, b2rdf, and b2rss2 for about a month after upgrading. They're set up to redirect aggregators to the new syndication files. Removing those would break that.
    You can also can b2-img/, b2-includes/, blog.header.php, and layout2b.css.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.