WordPress.org

Ready to get started?Download WordPress

Forums

What have I done wrong - cannot bring up on localhost (4 posts)

  1. JimiDad
    Member
    Posted 10 months ago #

    Hi Everyone,

    Hoping you can help me out here.

    I have a wordpress site up and running using IIS. No drama's.

    However, I am in the process of registering a new domain as DynDns have cancelled my free one.

    The problem I have now is that whatever I try, I cannot access my site locally.

    Can someone please advise exactly what I need to do in order to edit my site locally (whilst my registration comes through).

    At the moment, I have the WP_SITEURL set to 'localhost/blog'.

    Within IIS, my Sitename is 'Wordpress', with the '/Blog' application coming immediately underneath this.

    The error I see when I look up localhost/Blog via a web browser is this -

    HTTP Error 404.0 - Not Found
    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
    Detailed Error Information
    Module IIS Web Core
    Notification MapRequestHandler
    Handler PHP53_via_FastCGI
    Error Code 0x80070002

    Requested URL http://localhost:80/Blog/localhost/blog/wp-login.php?redirect_to=http%3A%2F%2Flocalhost%2FBlog%2F&reauth=1
    Physical Path D:\Blog-Stuff\Blog\localhost\blog\wp-login.php
    Logon Method Anonymous
    Logon User Anonymous

    What I can't work out, is how the physical path is being constructed, because obviously it is wrong -

    It should be -

    D:\Blog-Stuff\Blog\wp-login.php

    but as you can see from the above error, it ends up as -

    D:\Blog-Stuff\Blog\localhost\blog\wp-login.ph

    Help appreciated !

  2. Kacomp
    Member
    Posted 9 months ago #

    Hi, you have a redirect set up somewhere. What is in your htaccess file?

  3. JimiDad
    Member
    Posted 9 months ago #

    Thanks,

    I'm not aware of a redirect. I'm on Windows 2008 R2, with IIS 7.5.

    Is there an equivalent place i should be looking?

    Its' almost as if localhost is set as a parameter with a default set of values.

  4. Anastis Sourgoutsidis
    Member
    Posted 9 months ago #

    It seems you're trying to access http://localhost:80/Blog/localhost/blog/ which kinda relates to D:\Blog-Stuff\Blog\localhost\blog\
    What if you try accessing http://localhost/Blog/ ?

Reply

You must log in to post.

About this Topic

Tags

No tags yet.