WordPress.org

Ready to get started?Download WordPress

Forums

What file permissions and should I upload in ASCII mode? (19 posts)

  1. realitysamples
    Member
    Posted 8 years ago #

    I am installing a fresh verion of WP 1.5 and there is no info about what permissions to set the files at in the install instructions.

    Also should I be uploading in ASCII mode?

    Thanks!

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Folders 755
    Files 644 except theme files that you want to change with the online editor which should be 666
    ASCII mode is the one, yes :)

  3. spencerp
    Member
    Posted 8 years ago #

    ASCII mode for the "text" (.php files, .htaccess and such) files. And binary mode for the images. And usually just uploading the files will be basically set right for cmodding permissions. But I sometimes do whatever to make sure it's ok. What I find to be easier and that's just me, is installing it via the Control Panel... Fantastico. Other's might give a link for more informations about this or maybe even will tell you what gets cmodded what. Like the wp-config should be something "specific" and such. I think 644 or 666 maybe...correct me if I'm wrong.

    spencerp

    Sorry about that Podz lol...was posting just as you were posting I guess. =)

  4. moshu
    Member
    Posted 8 years ago #

    Yes, the files should be uploaded as ASCII. (I always set my ftp client to automatically recognize files).
    As for permissions, again the default settings usually are OK, but if you want a detailed list, go here:
    http://www.tamba2.org.uk/wordpress/chmod/

  5. realitysamples
    Member
    Posted 8 years ago #

    Ok so I did everything right then... wierd.

    When I type in the full path where the install.php is located I get redirected to my 404 page.

  6. realitysamples
    Member
    Posted 8 years ago #

    I assume WP should be uploaded in my cgi-bin folder.. but it does not say that in the instructions.

    Do I just upload in root?

  7. moshu
    Member
    Posted 8 years ago #

    Never in cgi-bin!
    If you want it to be the main feature of the site --> in the root. Or, if you want it in folder (e.g. "blog") create the folder and upload it there.

  8. realitysamples
    Member
    Posted 8 years ago #

    That's the problem then.. lol

    Thanks guys :)

  9. realitysamples
    Member
    Posted 8 years ago #

    ok I installed it in a folder called blog but did not realize the path to main page would be domain.com/blog/

    I needed to install in root instead so I reinstalled it script.

    I got a new error. http://www.realitysamples.com/wp-admin/install.php

  10. realitysamples
    Member
    Posted 8 years ago #

    I deleted the blog folder before I uploaded into root so wouldint that clear my old db tables?

  11. moshu
    Member
    Posted 8 years ago #

    It's exactly as it says :)
    Regardless where the files are, both times you have in the wp-config.php file the same database - where it is already installed.
    Just go to admin > Options > General and change the two URIs to reflect the blog's new position (i.e. http://www.realitysamples.com )

  12. spencerp
    Member
    Posted 8 years ago #

    UPDATE: Dang I ain't quick enough lmao! Listen to moshu.. =)

    You appear to have already installed WordPress. To reinstall please clear your old database tables first.

    Just do the last part as it says...clear your old database tables, via the phpMyAdmin or however you have it setup in the main site's control panel. Or if it's already installed, just forget about running the install script again, and delete the files for the installation. Go to the control panel for wordpress and change the url to new location. I'm not sure about that, moshu might be able to tell ya better..

    spencerp

  13. moshu
    Member
    Posted 8 years ago #

    I don't know what are you doing, realitysamples.
    I could see your blog at the address above (your sitename) - just without the style. The only thing you needed to do was what I posted above. Hope you know what are you doing :)
    Now the blog is gone.

  14. realitysamples
    Member
    Posted 8 years ago #

    I got it working in the blog folder
    http://www.realitysamples.com/blog/

    But when I change the url's in the options (by removing the /blog) and click "view site" i get 404.

  15. spencerp
    Member
    Posted 8 years ago #

    Try just moving them files from the "blog" folder right inside the root directory.
    http://wordpress.org/support/topic/49222 Might help ya a little bit. Meaning, what I do is, select all inside the "blog" directory... and move to "outside" that directory via your FTP software, which will or should move it to the root directory..that's if your site's link is also changed inside the wordpress control panel to just the domainname.com without blog on end...(do that first before attempting that though, I'm pretty sure it will work)

    spencerp

    Moshu, correct me if I'm wrong about that...or maybe you have an easier way of doing this lol..

  16. moshu
    Member
    Posted 8 years ago #

    OK, just calm down :) I know when an install goes wrong nobody really reads the posts here...
    1. You said first there was an installation in the /blog/ folder.
    2. Then you moved the files into the root and wanted to install it again. WP said: oops, it's installed.
    3. I said: Change the two option and your WP will be in the root (though didn't say it, I meant - don't touch anything else)

    If it works, that's fine. If you'll decide to move it in the future, read Moving_WordPress.

  17. realitysamples
    Member
    Posted 8 years ago #

    Moving the files did not work.. When I try to login my username and pass is no good.

  18. realitysamples
    Member
    Posted 8 years ago #

    bingo! fixed..

    Couldint have done it without you guys :o)

    I am blown away how fast support is here.. Almost like a chat room.. lol

    Keep up the good work guys.

  19. spencerp
    Member
    Posted 8 years ago #

    LOL! <thinks> If your blog is going to be like that from now on...I just might bookmark it for some stuff or something....lmao!! But then again, I have enough of that stuff to upload yet to my gallery to last a few years hahaha.. Im glad to hear it's working now.. =)

    spencerp

Topic Closed

This topic has been closed to new replies.

About this Topic