WordPress.org

Ready to get started?Download WordPress

Forums

What does this mean? (8 posts)

  1. OllieO
    Member
    Posted 7 years ago #

    Parse error: parse error, unexpected $end in C:\xampplite\htdocs\wordpress\wp-config.php on line 21

  2. chaaban
    Member
    Posted 7 years ago #

    you have a syntax error in your php code ...

  3. OllieO
    Member
    Posted 7 years ago #

    Not knowing how to spot a syntax error...how would I fix my wp-config.php file?

    Thanks for your reply.

  4. Start with a fresh copy and put your database details back in.

  5. jlmaggetto
    Member
    Posted 7 years ago #

    Hi,

    I have the same problem with a wp-config.php that I have just unzipped from wordpress-2[1].0.5.zip. The whole directory structure has been placed under xampplite/htdocs that I have installed just before. Apache and MySQL are running and configured (wordpress database created).
    I have followed the procedure described in http://www.tamba2.org.uk/wordpress/xampp/ for the "5 min" WordPress installation and I have been losing my time on this for 2 hours now.
    I am also asking to myself where to find an en.mo file to be placed under the (not existing) wp-includes/languages directory. Maybe this is the problem.

    A lot of thanks in advance for helping.

    Cheers,

  6. moshu
    Member
    Posted 7 years ago #

    No, you don't need an en_US.mo file (or anything like that) if your blog is in English. By default WP is in English.

    If you have a similar error to that posted in the original post (OP) then you altered your wp-config.php file and the code in it is not correct.

  7. jlmaggetto
    Member
    Posted 7 years ago #

    Hi again,

    Here is the code :

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', "); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'EN_US');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');

    ?>

    I have just altered the DB parameters as required, and I have checked that ABSPATH is correct.
    The error always refers to the last line (here it is line 22). Maybe there is something wrong in wp-settings.php ?

    Thanks again for trying to help.

  8. jlmaggetto
    Member
    Posted 7 years ago #

    OK, I will answer to myself.
    Being not a PHP programmer, I have discovered tonight that " (double quote) is not the same as '' (two single quotes) in PHP. This was a small exercise for PHP beginners.
    I have finally got the WordPress installation page !
    Let's proceed to the next problem.

    Good night...and good luck !

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags