WordPress.org

Ready to get started?Download WordPress

Forums

What do this mean? (9 posts)

  1. Notoriouz
    Member
    Posted 10 years ago #

    I am installing the wordpress and after i got mysql configured I read the following!
    Step 1
    Okay first we’re going to set up the links database. This will allow you to host your own blogroll, complete with Weblogs.com updates.
    Installing WP-Links.
    Checking for tables...
    Can't find table 'wp_linkcategories', gonna create it...
    Can't create the table 'wp_linkcategories' in the database.
    CREATE TABLE wp_linkcategories ( cat_id int(11) NOT NULL auto_increment, cat_name tinytext NOT NULL, auto_toggle enum ('Y','N') NOT NULL default 'N', show_images enum ('Y','N') NOT NULL default 'Y', show_description enum ('Y','N') NOT NULL default 'Y', show_rating enum ('Y','N') NOT NULL default 'Y', show_updated enum ('Y','N') NOT NULL default 'Y', sort_order varchar(64) NOT NULL default 'name', sort_desc enum('Y','N') NOT NULL default 'N', text_before_link varchar(128) not null default '
    ', text_after_link varchar(128) not null default '
    ', text_after_all varchar(128) not null default '', list_limit int not null default '-1', PRIMARY KEY (cat_id) )
    Access denied for user: 'leneldenhamjr@localhost' to database 'mysql'
    Can't find 'wp_links', gonna create it...
    Can't create the table 'wp_links' in the database.
    CREATE TABLE wp_links ( link_id int(11) NOT NULL auto_increment, link_url varchar(255) NOT NULL default '', link_name varchar(255) NOT NULL default '', link_image varchar(255) NOT NULL default '', link_target varchar(25) NOT NULL default '', link_category int(11) NOT NULL default 0, link_description varchar(255) NOT NULL default '', link_visible enum ('Y','N') NOT NULL default 'Y', link_owner int NOT NULL DEFAULT '1', link_rating int NOT NULL DEFAULT '0', link_updated DATETIME NOT NULL DEFAULT '0000-00-00 00:00:00', link_rel varchar(255) NOT NULL default '', link_notes MEDIUMTEXT NOT NULL default '', PRIMARY KEY (link_id) )
    Access denied for user: 'leneldenhamjr@localhost' to database 'mysql'
    Did you defeat the boss monster at the end? Great! You’re ready for Step 2.

  2. NuclearMoose
    Member
    Posted 10 years ago #

    Did you create wp-config.php and ensure that you entered in the correct database name, user name, and password for your database?
    If not, then you can simply copy wp-config-sample.php, then re-name it to wp-config.php.
    Once you have done that, go into the file and look for:

    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'username'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    Then substitute the values as indicated. If you have already done this, then ensure that the information is correct. Also, ensure that you have not accidentally added any extra spaces or line returns at the end of the file. If this does not solve your problem, then post back right away. It will be helpful to know which version of WordPress you are working with, as well.
    Craig.

  3. Notoriouz
    Member
    Posted 10 years ago #

    I have the new version of the wordpress....I just configured my config to say....
    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define('DB_NAME', 'mysql'); // The name of the database
    define('DB_USER', 'doomed'); // Your MySQL username
    define('DB_PASSWORD', '3996'); // ...and password
    define('DB_HOST', 'mysql'); // 99% chance you won't need to change this value
    Now what will I put in these settings because I think they are correct....
    On MyAdmin it shows the database as mysql...is this correct...If only I could get someone that had Instant messengers I could send you screenshots

  4. Notoriouz
    Member
    Posted 10 years ago #

    When I logged into my phpMyAdmin it would not work with anything else....I was owndering why I gad to have the db_name be mysql....how to I get it ro be named what I want it to be!

  5. Root
    Member
    Posted 10 years ago #

    Does it not say in the last words "great you are ready for step two.". Looks harmless to me so I would carry on to step 2 (For regular readers - this looks like the shushbh effect). If you ftp your screen shots to your host and give us the uri (address) we can see them.

  6. bruce2004
    Member
    Posted 10 years ago #

    ?? my sql gives option create database, you name it
    option to create user and set passwords
    add user to database with list of permissions
    enter above names into config file
    done.
    Is the database empty?

  7. Notoriouz
    Member
    Posted 10 years ago #

    Now I feel so stupid and after all that work I FINALLY GOT IT TO WORK>>>WOOOOHOOOO
    So if anyone needs help....just take a deep breath because now that I see how I feel so stupid.
    Thanks for you guys patience with me!

  8. Root
    Member
    Posted 10 years ago #

    Welcome to Word Press.

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    Hi -- I seem to be having the identical problem. I'm using the latest
    version of wordpress. I just installed php and mysql on my own server, so perhaps this is the problem, but they both seem to be working as expected. I get the same error message as above on
    Step 1
    Can't find table 'wp_linkcategories', gonna create it...
    Can't create the table 'wp_linkcategories' in the database.
    ...
    ', text_after_all varchar(128) not null default '
    ', list_limit int not null default '-1', PRIMARY KEY (cat_id) )
    Access denied for user: 'wordpress@localhost' to database 'wordpress'
    whereas the command
    /usr/local/mysql/bin/mysql -uwordpress -p wordpress
    works just fine with the same password.
    i checked that the database is called what i think it is and exists:
    mysql> show databases;
    +-----------+
    | Database |
    +-----------+
    | test |
    | wordpress |
    +-----------+
    do i need to do something else to set it up??
    the error message is occuring at:
    http://sansa.uchicago.edu/~risa/wordpress/wp-admin/install.php?step=1

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.