WordPress.org

Ready to get started?Download WordPress

Forums

What Are These Additional Characters? (4 posts)

  1. 4020
    Member
    Posted 2 years ago #

    I've been trying to add some affiliate code to my site which creates a flight search widget.

    The HTML view shows the code correctly when I input it.

    However, the link which appears on the live page sends visitors to an incorrect place.

    When I check carefully I see that the source code contains some extra characters which the affiliate informs me is where the problem lies.

    More specifically the offending characters are #038;

    So for example,

    THIS:
    http://www.jdoqocy.com/click-1303669-10644872?sid=&url=@@url@@

    BECOMES THIS:
    http://www.jdoqocy.com/click-1303669-10644872?sid=&url=@@url@@

    The affiliate tells me that I must remove #038; to make the widget work correctly but this is not an option as these characters do not exist in my HTML code, only in the live source code.

    Any suggestions would be most welcome.

    By the way ... the exact same code works just fine on a static website created in Expression Web.

  2. What kind of widget are you putting it in?

    It's possible the link's being sanitized and that's why the #038; is slipping in.

  3. 4020
    Member
    Posted 2 years ago #

    See the "Who Flies" search box at:

    http://www.spanish-fiestas.com/barcelona/flights.htm

    This is the site where it works.

    Now look at:

    http://dev.spanish-fiestas.com/barcelona/flights/

    This where the search box is sent to the wrong place (we think) due to the extra characters.

    The full code that should create the search box is as follows:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    I've tried leaving it as it is & placing it inside my own <div> but the result is the same.

    Here's the source code that is generated with the extra characters:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    You can see that #038; crops up in a few places.

  4. 4020
    Member
    Posted 2 years ago #

    Sorry for breaking the forum rule on code pasting above. I wasn't aware of it.

    As for the code type that's causing the problem it's text/javascript.

    Still can't work it out.

    Any suggestions please?

Topic Closed

This topic has been closed to new replies.

About this Topic