WordPress.org

Ready to get started?Download WordPress

Forums

We're having a little trouble selecting the prope (27 posts)

  1. xMEEPYx
    Member
    Posted 10 years ago #

    Ahg!
    We're having a little trouble selecting the proper database for WordPress.
    *Are you sure it exists?
    *Your database name is currently specified as Bloggage. Is this correct?
    *On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?
    I don't er... remember making a DB.. I named one in wp-config.php, but I dunno if I 'made' one..
    I'm pretty sure I have wp-config right. I uploaded everything correctly, too.. I'm so confused ::cries:: =P Help would be greatly appreciated ^_^

  2. MattRead
    Member
    Posted 10 years ago #

    Do you have access to CPanel or PHPmyAdmin on your host? If so, you bassically just click on create a database, then set wp-config to that database.

  3. xMEEPYx
    Member
    Posted 10 years ago #

    Ok.. I did that.. but it still gives me the same error.. But now it has my new database's name.
    We're having a little trouble selecting the proper database for WordPress.
    Are you sure it exists?
    Your database name is currently specified as tddwckbi_bloggage. Is this correct?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

  4. xMEEPYx
    Member
    Posted 10 years ago #

    Oops.. I had the wrong user for the database.. I fixed it and now I get a new error.. or.. well, errors
    Warning: Cannot modify header information - headers already sent by (output started at /home/tddwckbi/public_html/wp-config.php:31) in /home/tddwckbi/public_html/wp-login.php on line 122
    Warning: Cannot modify header information - headers already sent by (output started at /home/tddwckbi/public_html/wp-config.php:31) in /home/tddwckbi/public_html/wp-login.php on line 126
    Warning: Cannot modify header information - headers already sent by (output started at /home/tddwckbi/public_html/wp-config.php:31) in /home/tddwckbi/public_html/wp-login.php on line 129
    Warning: Cannot modify header information - headers already sent by (output started at /home/tddwckbi/public_html/wp-config.php:31) in /home/tddwckbi/public_html/wp-login.php on line 131
    Warning: Cannot modify header information - headers already sent by (output started at /home/tddwckbi/public_html/wp-config.php:31) in /home/tddwckbi/public_html/wp-login.php on line 132
    Warning: Cannot modify header information - headers already sent by (output started at /home/tddwckbi/public_html/wp-config.php:31) in /home/tddwckbi/public_html/wp-login.php on line 133
    Warning: Cannot modify header information - headers already sent by (output started at /home/tddwckbi/public_html/wp-config.php:31) in /home/tddwckbi/public_html/wp-login.php on line 134
    Warning: Cannot modify header information - headers already sent by (output started at /home/tddwckbi/public_html/wp-config.php:31) in /home/tddwckbi/public_html/wp-login.php on line 154

  5. Beel
    Member
    Posted 10 years ago #

    No need to copy the entire list of warning messages. There is whitespace in the file "wp-login.php" - delete any carriage returns or spaces before the opening "<?php" and after the closing "?>" in that file.

  6. xMEEPYx
    Member
    Posted 10 years ago #

    All the spaces? There's A LOT of spaces..

  7. Beel
    Member
    Posted 10 years ago #

    Now set your WP URI properly (it is currently set to the subdirectory of "main3" but actually resides in the root directory.

  8. xMEEPYx
    Member
    Posted 10 years ago #

    What's a carriage? WP URI? I can't seem to find that..

  9. xMEEPYx
    Member
    Posted 10 years ago #

    OK.. I deleted the spaces in wp-login.. How am I to edit the URI?

  10. xMEEPYx
    Member
    Posted 10 years ago #

    Whenever I enter in the password and hit enter, it basically refreshes and clears the fields (username and password)

  11. xMEEPYx
    Member
    Posted 10 years ago #

    Ahg.. How are you logged in and I'm not? I think I gave it the password it gave me.. but even if I didn't, it won't let me do a lost password thing.

  12. xMEEPYx
    Member
    Posted 10 years ago #

    phpMyAdmin is where? Aw man I feel like such a lamer haha

  13. xMEEPYx
    Member
    Posted 10 years ago #

    I found it.. I'm not that much of a lamer anymore. What do you want me to do in phpmyadmin?

  14. Beel
    Member
    Posted 10 years ago #

    Actually, you haven't done anything yet, so why not drop the entire database and run install.php again?

  15. xMEEPYx
    Member
    Posted 10 years ago #

    Ehg.. I'm in. I don't know how but I am. I'm at a new post and I made one! Now every post I make will be at index.php? Thank you sooo much ^_^

  16. xMEEPYx
    Member
    Posted 10 years ago #

    Last question and I'll be out of your hair forever =P Where do I put the style.css file for changing.. the css style hehe

  17. Beel
    Member
    Posted 10 years ago #

    You still have to change the URI under Options in the admin section.

  18. xMEEPYx
    Member
    Posted 10 years ago #

    What do I change it to? And why do I need to change it if everything is working?

  19. Beel
    Member
    Posted 10 years ago #

    Well, unless I am looking at the wrong place, it is not:
    http://www.tddwp.net/index.php

  20. xMEEPYx
    Member
    Posted 10 years ago #

    That's where WordPress is working:
    First?
    Filed under:
    General
    � Katie @ 12:47 am Edit This
    This would be the test xD
    Comments (0)

  21. xMEEPYx
    Member
    Posted 10 years ago #

    Is the subdirectory supposed to be a folder or a web page? What do I put in main3? I thought I was so close :(

  22. xMEEPYx
    Member
    Posted 10 years ago #

    So all the files that I've uploaded into the main directory have to moved into a subfoler (named.. um.. wordpress :P )? When you said "URIs in Options to" where's the options?

  23. Beel
    Member
    Posted 10 years ago #

    In the Admin section where you log in. You can have it wherever you want. Right now in Options you have it set to "main3"

  24. xMEEPYx
    Member
    Posted 10 years ago #

    But does "main3" have to be a folder where I keep all of the WP files?

  25. xMEEPYx
    Member
    Posted 10 years ago #

    YAYY! Somehow I got it.. You are so patient! I would have told me to give up a lonnnng time ago!! Thank you soooooooooooooooooooooo much!!!! ^_^!!!

  26. Beel
    Member
    Posted 10 years ago #

    Voila! Now doesn't that look much better?? I am off to bed.

  27. xMEEPYx
    Member
    Posted 10 years ago #

    Aw!! I'm sorry I made you stay up! Thank you soo much once again!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.