WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Welcome URL not found (20 posts)

  1. pappilogic
    Member
    Posted 3 years ago #

    Hi,

    Created a ‘Welcome’ page for http://www.sweetgrass-baskets.com/ (permalink shows http://www.sweetgrass-baskets.com/). Went to Dashboard/Settings/Reading and made ‘Welcome’ the static ‘Front Page:’ w ‘Articles’ as the ‘Posts Page:’ However, when I try to view the ‘Welcome’ page, instead of going to http://www.sweetgrass-baskets.com/, the site comes back w http://www.sweetgrass-baskets.com/southwest-baskets/ w a ‘Error 404 - Not Found’ msg.

    Note: Had previously created a southwest-baskets page in error; should have been an article. Subsequently, went back and deleted southwest-baskets, and created a southwest-baskets page.

    Under Settings/General, http://www.sweetgrass-baskets.com/ is shown both in the WordPress address and the Site address. Permalink settings set to default. Tried the other permalink options and they displayed display the southwest-baskets article.
    Went through all the other WP settings, but could find no redirects. Tried clearing recent history, but that had no effect.
    Everything was working fine up until recently, but don’t know what happened to cause this problem. Any ideas as to what to do next?

    Thanks,
    Larry

  2. Samuel B
    moderator
    Posted 3 years ago #

    you need to re-save your permalinks as you have a sort of mixed bag now
    for example, I can go here
    http://www.sweetgrass-baskets.com/?page_id=1
    then navigate freely to other pages

    personally, I would use a custom permalink of
    /%postname%/
    for what you are doing

  3. pappilogic
    Member
    Posted 3 years ago #

    Thanks, Samuel. I'll give it a try

  4. pappilogic
    Member
    Posted 3 years ago #

    Problem not solved after doing the following:
    - Deleted ‘Welcome’ page
    - Went to Settings/Permalink Settings/Common Settings/Custom Structure & added /http:/www.sweetgrass-baskets.com/%postname%/
    - Created, Published & Viewed new ‘Welcome’ page which looked fine
    - Went to Settings/Reading Settings & selected new ‘Welcome’ page as the static page/Front page: and ‘Articles’ as the Posts page:
    - Went back to Pages/Welcome page (permalink - http://www.sweetgrass-baskets.com/) & clicked on ‘View page’. http://www.sweetgrass-baskets.com/http:/www.sweetgrass-baskets.com/southwest-baskets/ came up. Clearing the cache didn’t help.

    Can’t find the place where this can be cleaned up. Appreciate any help.

    Thanks,
    Larry

  5. Went to Settings/Permalink Settings/Common Settings/Custom Structure & added /http:/www.sweetgrass-baskets.com/%postname%/

    That's not a valid permalink structure. Use just /%postname%/

    http://codex.wordpress.org/Using_Permalinks

  6. Samuel B
    moderator
    Posted 3 years ago #

    as James pointed out, never use a url in permalink structure

  7. pappilogic
    Member
    Posted 3 years ago #

    Went back to Settings/Permalink Settings/Common Settings/Custom Structure & changed to /%postname%/.

    Opened 'Welcome' page to edit. The 'Welcome' page looks fine when doing a Preview Changes in the Publish box, but when clicking on the View page under the Edit Page header, program still goes to http://www.sweetgrass-baskets.com/southwest-baskets/ w Error 404 - Not Found.

  8. Did WordPress provide instructions for you to edit the .htaccess file after saving the permalink structure?

  9. pappilogic
    Member
    Posted 3 years ago #

    Hi James,

    Not that I'm aware of. This is an area in which I have virtually no knowledge.

  10. Access your server via FTP or SFTP. Do you see a .htaccess file in the same directory as your wp-load.php file?

  11. pappilogic
    Member
    Posted 3 years ago #

    Went into the cpanel then File Manager. Did a search for the 2 files you mentioned, but neither could be found.

  12. If wp-load.php wasn't there, your blog wouldn't load at all. Try using an FTP or SFTP client.

  13. pappilogic
    Member
    Posted 3 years ago #

    Found the wp-load.php file, but there was no .htaccess file in the same directory.

    Have 4 other sub-domains and they don't have any problems.

    Using cPanel & file manager to access files on the server and the Upload utility to transfer files to the server.

  14. In that case, use a plain text editor to create an empty file called .htaccess and upload it to the same directory as the wp-load.php file, then change the permissions of the file to 666, and try saving your permalink structure again at Settings/Permalinks.

  15. pappilogic
    Member
    Posted 3 years ago #

    Went to /public_html/sweetgrass-baskets.com in cpanel and did a search for .htaccess. It came back w /public_html/sweetgrass-baskets.com/.htaccess, but can't find that file anywhere in the file listing. Other than 4 additional directories, there are only 4 non-php files (license, readme & 2 sitemap files.

  16. pappilogic
    Member
    Posted 3 years ago #

    Found the .htaccess file (hidden file) and changed the permissions to 666. Went back to Settings/Permalinks where the Common Settings/Custom Structure was selected w /%postname%/ in the box. Still got a redirect to http://www.sweetgrass-baskets.com/southwest-baskets/ instead of http://www.sweetgrass-baskets.com/. Also tried Common Settings/Default, but got the same results.

    Went to Tools/Redirection/Redirects and there were no redirects. Under Tools/Redirection/Modules there were 3 listings: WordPress - Disabled: You must enable permalinks before using this, Apache - Disabled: enter the location of an .htaccess file for this to be valid & 404 Errors.

    Don't know why WordPress permalinks are not enabled. The edit function didn't provide a way to activate permalinks. Edited the Apache module to list /home/chrissie/public_html/sweetgrass-baskets.com/ as the .htaccess file location.

    Today's date was the only entry in the Redirections Log, and it showed a Redirect to: /southwest-basket.

    The changes had no effect on being able to get to the home page.

    Note: Going to Pages/Welcome (static page) and clicking on 'View' the screen comes up blank. The same thing happens when clicking on 'Permalink: http://www.sweetgrass-baskets.com/ View Page' under the header, but when 'Preview Changes' is clicked in the 'Publish' box, the Welcome page displays properly.

  17. pappilogic
    Member
    Posted 3 years ago #

    Reading through the Permalink information, decided to re-create the .htaccess file following the instructions provided by WP.org. Unfortunately, there were several problem w the instructions:
    # Delete all contents from your .htaccess file and click the Update File button. The file can't be saved if there is no content.
    # In the Control Panel, go to Options > Permalinks. HostGator has no Options > Permalinks category.

    The only thing in the .htaccess file is:
    # BEGIN WordPress

    # END WordPress

    Is there an alternate way of generating a new set of htaccess rules?

  18. Try deactivating the Redirection plugin. It causes problems with WP 3.

  19. pappilogic
    Member
    Posted 3 years ago #

    Thanks, James. Didn't know there was a redirect plugin. Deactivated it, and all is well.
    Thanks again,
    Larry

  20. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic