WordPress.org

Ready to get started?Download WordPress

Forums

WEIRDEST PERMALINK PROB EVER.. (10 posts)

  1. mccammog
    Member
    Posted 8 years ago #

    I can see the front page of my blog fine but if i try to click the title of any posts, their comment buttons, or the category links from where they are posted, or any category links and archive links from the side, i get a 404 error.. HELP!

    so i figure my permalinks are buggy.

    /archives/%postname%/

    thats them.

    I try to change them but everytime i press the permalinks tab, the next time i press ANY LINK AT ALL LINKING TO ANY PART OF MY BLOG, i get a 500 error, so i cant even change it to something more reasonable like,

    /%year%/%monthnum%/%day%/%postname%/

    .. problem.

    any one got a solution?

  2. vkaryl
    Member
    Posted 8 years ago #

    Did you make sure your .htaccess file is writeable (set at 777) until you've made the changes? Then before you try ANYTHING else, go back to the server, and change the .htaccess file to 644, then try a post link. May not work, though it almost always does for me.

    And please don't use all-caps for your title....

  3. mccammog
    Member
    Posted 8 years ago #

    the htaccess file is gone, becuase i deleted it becuase of the problem. So i went to the permalink options page, and refreshed my FTP, and a htacess file had been made. However, no matter what i set it to, 777 even, it is still the same result after going to another site. It seems like whenever I have an htaacess i cant even access the darn site.. just 500 errors for everything.

  4. mccammog
    Member
    Posted 8 years ago #

    the htaccess file is gone, becuase i deleted it becuase of the problem. So i went to the permalink options page, and refreshed my FTP, and a htacess file had been made. However, no matter what i set it to, 777 even, it is still the same result after going to another site. It seems like whenever I have an htaacess i cant even access the darn site.. just 500 errors for everything.

  5. vkaryl
    Member
    Posted 8 years ago #

    What happens if you delete everything out of the htaccess file using your ftp client or control panel? Leaving it completely empty, I mean....

    Have you checked with your host to see if they have any ideas?

  6. mccammog
    Member
    Posted 8 years ago #

    strange, i tried that, left the file completely empty. I could go around the site like normal but post links and all left me 404's.. :-\

  7. mccammog
    Member
    Posted 8 years ago #

    umm.. please?

  8. ceo
    Member
    Posted 8 years ago #

    Is mod_rewrite enabled on your server?

    Also, I know that on my old host I needed to have FollowSymLinks in my htaccess to get permalinks to work. You might want to search this board for some other tricks you might use.

    EDIT: Also, not to sound mean, but it's really rude to have your subject be in all caps - personally I would usually steer clear of such a thread. It's not very considerate.

  9. nearlythere
    Member
    Posted 8 years ago #

    from your initial post, you're saying that you can't click 'the permalinks' tab in your admin area?

    so- the links aren't working in your admin area?

    if so your problem is not related to permalinks. i've broken all my permalinks, and my admin area still works.

    please post a link, if you can, it makes it easier and quicker to help out.

  10. tomhanna
    Member
    Posted 8 years ago #

    Solution - turn off custom permalinks. Delete the htaccess file. Don't mess with custom permalinks because something in your server isn't compatible.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags