WordPress.org

Ready to get started?Download WordPress

Forums

Weird Spam Karma Issue (16 posts)

  1. phiali
    Member
    Posted 9 years ago #

    Evening,

    I have been receiving quite a bit of evil comment spam over the past few days so this morning I installed the wonderful Spam Karma and it's eaten around 45 pieces of spam (yay!).

    Slight issue in that when a valid comment is detected as potential spam the captcha form is not displayed at all ... all the intro text is there but no captcha form or email thing either?

    Inside wp-content/ there is spam-karma with a chmod of 777 and inside wp-content/plugins i have spam-karma.php

    Any ideas at all? Really want to get this little best working 100% :)

  2. Which version are you using right now? The latest is 1.14.

  3. phiali
    Member
    Posted 9 years ago #

    Am using 1.14 alpha 5 which I downloaded today

  4. Since we're both using Kubrick at the moment, could you test out the same type comment on mine? I hope the same isn't happening to me, and I'm unaware.

  5. phiali
    Member
    Posted 9 years ago #

    btvillarin you seem to have the exact same issue as me - the "Comment Verification" page is showing up without any forms or captchas there.

    The URL called was http://blogged.btvillarin.com/wp-content/spam-karma/captcha_confirm_form.php?c_id=101&c_author=Alistair

    You should see my comment waiting in moderation. Could this be a Kubrick issue then?

    I did a View -> Source in IE from the result I got and it's available here http://www.0gravity.co.uk/sk.html

  6. I definitely see it in moderation. (Deleting it right now.)

    Perhaps you can drop a line or two (link to this thread) and ask him about it? I'm not sure what to do, other than maybe switching to Kitten's Spaminator. *shrugs*

  7. phiali
    Member
    Posted 9 years ago #

    Well sent an email off and will let you know what happens!

  8. Thanks man! :)

  9. motato
    Member
    Posted 9 years ago #

    Hi, I just installed this script as well, and it was working fine-- all the spam was being eliminated before my eyes.... unfortunately, it's not allowing regular comments to be posted (from people I know with comments I would like to read)... so I was wondering if I need to have particular settings to prevent this from happening, or if I have to lower leniency or something? (I had Kitten's Spaminator installed previously, but a significant amount of spam was still getting posted so I thought I should try this one out...)

  10. 7milesdown
    Member
    Posted 9 years ago #

    ^^ Im having the same issues. I installed, and eats spam like nothing. But hard to get comments by regulars. hmmmm

  11. phiali
    Member
    Posted 9 years ago #

    *bump* Okay people got some update to this thanks to drDave.

    He's advised me to install the latest version (which was 1.16alpha at the time) and run the test "Captcha" script to ensure that you (well your host) meet the requirements to use the Captcha.

    It turns out that my host needs to get freetype installed so I'm out of luck for the moment. Plus, at the moment you cannot get form authorisation unless you also use a captcha.

    What I did turn off was the the HTTP_VIA option as regular comments were getting eaten when that was switched on. I think thats to show that the person came in via a proxy server.

    I've switched that option off as well as captcha and form authorisation and the spam is still getting kept out and it *seems" regular comments are getting through.

    Don't suppose that anyone might care to test leaving a comment on the site?

  12. ceo
    Member
    Posted 9 years ago #

    macmanx's thread about Spam Karma reminded me of this thread - I've never been able to get the captcha to work - above it says that your host needs to have FreeType installed (and mine does), but I still don't know how to get the image to show up. :(

    Figured I'd see if in the month since the last reply if anyone's found a solution.

  13. Yeah, when using the Captcha test page, I get this error:
    -Captcha-Debug: Check given TrueType-Array! (1)
    -Captcha-Debug: Valid TrueType-files: (0)No Truetypefont available for the CaptchaClass.

    Looking at Gudlyf's AuthImage page, there is comment to alter AuthImage in order to bypass FreeType, but I don't know how to implement it in Spam Karma. See: http://www.gudlyf.com/index.php?p=376#comment-565

  14. oellefsen
    Member
    Posted 9 years ago #

    I've just started using Spam Karma 1.19 alpha1, running on a Gentoo based server. At first the captcha test failed complaing about missing freetype support. I set the relevant USE flags and recompiled Imagemagick and GD with truetype support, and installed freetype to make the fonts available.

    The the test then worked fine, but no image was displayed. That was easy to fix by setting write permissions on the wp-content/spam-karma/captcha_temp folder

    Great plugin, it ate 96 trackback spam today :-)

  15. drdave
    Member
    Posted 9 years ago #

    Hi there,

    For anybody experiencing any sort of issue with SK1 (whether with false positives, or that pesky captcha display), I'd recommend upgrading to SK2 pre-alpha (very soon to become alpha). Seeing how these issues (and much more) have been addressed and there hasn't been any major bugs reported so far, there's little to lose here.

    Beware that you need to upgrade your WP install to fix a bug present in the original 1.5 release (see details here: http://unknowngenius.com/blog/wordpress/spam-karma/dev/)...

    For those 100% happy with their current install of SK, I suppose you can wait for the first public beta (itself waiting on WP 1.5.1 release, which should be rather soon). But feel free to take the jump now: there is quite a lot of improvement to be enjoyed with this new version.

    thanks everybody...

  16. davincim
    Member
    Posted 9 years ago #

    DrDave, I'm running WP v1.5 and I just installed SK2. I'm getting this message when I try to post a comment:

    Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/galen5/familywebwatch.com/blog/wp-content/plugins/SK2/sk2_util_class.php:145) in /hsphere/local/home/galen5/familywebwatch.com/blog/wp-comments-post.php on line 44

    Actually, I'm getting a lot more than that. Basically, it's the same with the line number increasing by one. And to add to the confusion, if I go back to my form (from the error messages) and refresh, my comment shows up.

    Can you help?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.