WordPress.org

Ready to get started?Download WordPress

Forums

Weird problem.... (13 posts)

  1. yeleek
    Member
    Posted 8 years ago #

    WordPress was working fine. No worries. Now however clicking on any posts or catagories etc and a 404 not found error is now displayed. Any ideas?

    http://www.yeleek.co.uk

    Many thanks

    Ben

  2. yeleek
    Member
    Posted 8 years ago #

    Fixed it. One of the plugins wanted to change the permalink option. So I did... Changed it back to default. It works.

    Question has to be then. Can the permalink options be changed without having a negative effect on previous posts?

    Thank you

    Ben

  3. Christopher J. Hradil
    Member
    Posted 8 years ago #

    I'm not getting the errors, everything looks good to me using IE, haven't checked it with anything else. Browser shouldn't be an issue. One thought however, depending on how you are setting your permalinks (it looked like they were either off or set to "default" when i checked, and what type of server you're running on, if the MS Frontpage extensions are installed on the server, permalinks won't work. Which sounds like the problem you were describing.

  4. moshu
    Member
    Posted 8 years ago #

    Define "negative effect".

  5. Christopher J. Hradil
    Member
    Posted 8 years ago #

    yes, you should be able to change your permalink settings, either the server doesn't have mod_rewrite working or the MS frontpage extensions are installed. If either is the case your permalinks aren't going to work unless you either get mod_rewrite working or uninstall the Frontpage extensions.

  6. Christopher J. Hradil
    Member
    Posted 8 years ago #

    were you able to resolve the issue ?

  7. yeleek
    Member
    Posted 8 years ago #

    They are currently working. If i change the permalinks to use a different format though previous posts don't work. Should I be able to change the permalink style and previous posts etc still work?

    I will ask about Mod_rewrite/ MS frontpage extensions. Thanks!

    Ben

  8. Christopher J. Hradil
    Member
    Posted 8 years ago #

    You should be able to change the permalink style and all old content should work with no problem. It sounds to me like the Frontpage issue, or that mod_rewrite isn't working/enabled. I kind of like to use frontpage for making changes to sites "on the fly", and I had it all set up to use TopStyle as the CSS editor and Zend studio for php files, etc. I've had to remove the extensions from all the sites on my dedicated box though because I like the "date based" fancy permalinks, first because they bookmark well, second, search engines, google, etc, seems to like them, and that format is very similar to the w3c URI reccomendations, for long term usefulness of content on the internet. So, I've chosen to dump MS FP for now, and I'm working on finding a combo of design apps/editors that are similarly easy to work with. I'm still using topstyle for css and zend for php, it's just that everything isn't integrated as tightly anymore. I'm looking at Adobe GoLive as a possible FP replacement for general file/site management, html edits, etc, then tying in ZEND/TopStyle for appropriate file types.

  9. yeleek
    Member
    Posted 8 years ago #

    Hi,

    You were right. I had frontpage extensions installed. I've uninstalled them and now I believe my htaccess file has been removed as well.... Any ideas how i can get it recreated?

    Thank you

    Ben

  10. yeleek
    Member
    Posted 8 years ago #

    Ahh no worries. Created file gave it the permissions required and wordpress updated it. Thanks for all your help!

  11. Christopher J. Hradil
    Member
    Posted 8 years ago #

    Permalinks & MS Frontpage -

    There have been a number of threads on this issue, and I've updated the documentation in the codex to reflect the following information.

    Normally, on a Unix server with the Microsoft Frontpage Server extensions installed wordpress works just fine and you are able to
    edit and publish pages - UNTIL - you make a change to the permalinks (for example to the date based kind that I like /2005/04/etc).
    I often suggest that type of URI to folks asking about permalinks etc, as that is the method recommended by the w3c (see http://www.w3.org/Provider/Style/URI ).

    Now, the problem is that MS Frontpage uses the .htaccess file (which the wordpress mod_rewrite rules must go into) for it's "publishing" and
    "web authoring" configuration. As soon as the wordpress mod_rewrite code is added to the file, two things happen - the permalinks don't work, and the MS Frontpage Server extensions become corrupted.

    I have tried countless ways to get around this, including trying to use rewrite rules that "ignore" the %{HTTP_USERAGENT)% used by Frontpage, to using a second AccessFilename .wpaccess to the httpd.conf file, and a host of other things, and nothing worked so that a person would be able
    to both use MS Frontpage to manage the website and use the permalinks for wordpress at the same time.

    Until Now.

    The solution is acctually quite simple, and I kind of figured it out by accident.

    If you are using or wish to use MS Frontpage along with wordpress you'll need to take the following simple steps on your server (or have your hosting company do it for you).

    MS Frontpage creates the following directory
    _vti_bin

    Nested within that it creates both _vti_adm and _vti_aut

    In addition to in your website (or wordpress) root folder in all of those directories you will find a .htaccess file.

    In all three of these directories AND in the root directory, at the top of ALL of the .htaccess files you simply need to add one line -
    Options +FollowSymlinks
    close and save the files and you're done.
    Now everyhting works perfectly, including MS Frontpage, AND the permalinks of your choosing.

    On a personal note, I prefer to use Frontpage to manage/maintain sites, I've been using it since around '96, and by now, since I do most work on UNIX servers anyway I have it configured to use external editors for just about everything, including Zend Studio for php files, Bradbury TopStyle for stylesheets, Adobe ImageReady/Photoshop for images, etc. I'm more or less just using Frontpage as a convenient way to manage the site and access everything, etc. Then when I hit the "save" button in any of the other applications, they have Frontpage save my changes directly to the server, with no need to be FTP'ing files around, etc. It does help to get lots accomplished very quickly, and I was pretty bummed for the past year or so with the permalink frustration, since I was either needing to not use permalinks or not use Frontpage, or keep re-installing the FP extensions. At one point I found a way to make a .htaccess for my "running" site, but then change it to a FP .htaccess when I was doing any work (permalinks of course didn't work), either way it was a real pain.

    This should work with most versions of FP and most of the unix versions of the extensions in use today.

  12. Emory
    Member
    Posted 7 years ago #

    hi chradil,
    I took the steps above and changed all 4 .htaccess files. I still get the message that frontpage extensions aren't installed. I could reinstall fp extensions but I'm afraid it will blow out my current .htaccess with all urls working. Any thoughts on this? thanks.

  13. richiedude
    Member
    Posted 7 years ago #

    Same her e- followed to a "T" - in fact I got the exact same advice when adding morewrite code to force WWW in my website - did the above - and it works perfectly w/Frontpage extensions.

    The wordpress code is another issue however and breaks FP no matter what I do - including everything above.

    Funny - do the Options +FollowSymlinks as described above - with mod rewrite code to force www and it works. Replace with the permalink mod rewrite code - and BAM Fp extension are done.

    Something is missing.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.