WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Weird Permalink Problem - All pages work except index (2 posts)

  1. adityanag
    Member
    Posted 1 year ago #

    Hi,

    When I enable permalinks, the home page doesn't work, and all I see is the default Apache 2 Test Page.

    However, permalinks are working.. if I type in http://www.adityanag.com/about , it works perfectly. All the pages inside work too.. it's just the home page that doesn't work.

    If I disable permalinks, everything works perfectly, so Apache is picking up index.php

    I have checked AllowOverride, and it's set to All. Follow SymLinks is enabled.

    I don't know why the permalinks inside the site are working but the home page isn't.

    Here's my .htaccess file. Any help much appreciated.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    ~
  2. adityanag
    Member
    Posted 1 year ago #

    I fixed it. The weirdest fix ever.

    edit /etc/httpd/conf.d/welcome.conf

    from

    <LocationMatch "^/+$">
        Options Indexes
        ErrorDocument 403 /error/noindex.html
    </LocationMatch>

    to

    <LocationMatch "^/+$">
        Options -Indexes
        ErrorDocument 403 /error/noindex.html
    </LocationMatch>

    Yes. Adding a - before Indexes fixes this. Why? I have no idea. But it works now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.